All users were logged out of Bugzilla on October 13th, 2018

GUI page icon is displayed without being referenced by a 'link'-element

VERIFIED DUPLICATE of bug 109843

Status

VERIFIED DUPLICATE of bug 109843
17 years ago
10 years ago

People

(Reporter: subotnik, Assigned: bugzilla)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011114
BuildID:    20011114

Several sites that have no rel="... icon" defined in a link element show GUI
site icons today.

AFAICS this may only result in blind fetching for /favicon.ico.

This contradicts with the consensus Hyatt described in
<http://bugzilla.mozilla.org/show_bug.cgi?id=108823#c14>.

Seems like something has gone wrong with defaulting the hidden pref for
/favicon.ico grabbing to 'off'.

Reproducible: Always
Steps to Reproduce:
1. create a new profile (just to be shure that everythin is clean)
2. go to <http://www.excite.com/>
3. view source
4. there is no <link rel="... icon" ...> 

Actual Results:  There is an icon in the URL bar and in the tabs.

Expected Results:  There should be none, because non is referenced in the page.
QA Contact: sairuh → claudius

Comment 1

17 years ago
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/modules/libpref/src/init/all.js

  3.297  hyatt%netscape.com  Nov 13 00:55
  Turn on favicons in Mozilla. r=glazou, bryner, sr=ben,hewitt, bug 109843
The /favicon.ico consensus decision is on the branch.  On the trunk, fetching
/favicon.ico is on, presumably for testing purposes.

*** This bug has been marked as a duplicate of 109843 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.