Random 'Unable to find the proxy server'

RESOLVED DUPLICATE of bug 1123324

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1123324
3 years ago
3 years ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

({regression})

36 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8525518 [details]
Unable to find the proxy server screenshot

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141118030201

Steps to reproduce:

I use Fiddler web debugging proxy with Firefox nightlies. I'm using v4.4.9.6. I opened a new tab and attempted to search from the search box.

I was able to reproduce this in a new profile but only once. The exact steps I used were I went to Options then advanced > certificates, added the fiddler certificate, then advanced > network settings and set manual proxy configuration to localhost 8888 for all. Then I opened a new tab, pasted strstr in to the google search box and hit enter and I received 'Unable to find the proxy server'.


Actual results:

It is extremely rare that I will see 'Unable to find the proxy server' in a new tab when I search. For example in the profile I'm using now it went away and all connections are going through the proxy again. I don't believe this is the fault of Fiddler. I have used Fiddler with Aurora for a long time now without problems, but not Nightly. Today I enabled it in Nightly to test something else, then forgot I left it on.


Expected results:

The proxy server is working, it is a local debugging proxy. I don't see any record that the connections for search were attempted although I'm not doing something as low level as watching the TCP. If there is a better diagnostic in Firefox let me know and I can give you more information should it happen again.
(Reporter)

Comment 1

3 years ago
When I tried just now to view the screenshot I uploaded by clicking on the link in attachments I received another 'Unable to find the proxy server' message. Again Fiddler's log doesn't show anything. So this may not have anything to do with new tabs or search.
(Reporter)

Comment 2

3 years ago
This doesn't have anything to do with new tabs or search, if you can edit the title please do. I've been using Nightly through Fiddler Proxy for about two days now and I've seen 'Unable to find the proxy server' a few dozen times in existing tabs, partially loaded pages, etc.
Component: Untriaged → Networking
Keywords: regression, regressionwindow-wanted, steps-wanted
Product: Firefox → Core
Summary: Random 'Unable to find the proxy server' after searchbox in new tab → Random 'Unable to find the proxy server'
(Reporter)

Comment 3

3 years ago
This is still an issue in the latest nightlies. It happens at least several times a day.
(Reporter)

Comment 4

3 years ago
Still an issue. 38.0a1 (2015-01-13)

Comment 5

3 years ago
I can confirm this issue. It’s not associated with any particular action but occurs randomly when a proxy server is set using a host name (instead of an IP address). Most of the time, clicking reload “fixes” the problem.

More specifically, I use FoxyProxy with its default proxy set to “localhost:3128”, which is a SSH tunnel listening on both IPv4 (127.0.0.1) and IPv6 (::1).

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552
this sound similar to bug 1123324.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123324
Per Comment 17,clear "regressionwindow-wanted, steps-wanted".
Keywords: regressionwindow-wanted, steps-wanted
You need to log in before you can comment on or make changes to this bug.