Closed Bug 1102038 Opened 5 years ago Closed 5 years ago

the "Change Search Settings" button and the open search items cannot be used via the keyboard

Categories

(Firefox :: Search, defect)

x86
macOS
defect
Not set
Points:
5

Tracking

()

VERIFIED FIXED
Firefox 38
Iteration:
38.2 - 9 Feb
Tracking Status
firefox34 - wontfix
firefox35 --- wontfix
firefox36 --- wontfix
firefox37 --- verified
firefox38 --- verified

People

(Reporter: kjozwiak, Assigned: florian)

References

Details

(Keywords: access)

Attachments

(3 files, 1 obsolete file)

The "Change Search Settings" button cannot be selected when using the keyboard. Using the down arrow and the TAB key will skip the button.

Attached a .gif that demonstrates the issue.
[Tracking Requested - why for this release]: This is important for the accessibility of the search UI.
We decided this wasn't necessary for the first iteration (there are other ways to open the search settings via keyboard).
Extending this to also include open search items, as I think it makes sense to fix both at once.

I discussed this with Philipp this morning. After the decision we made in bug 1104142 about the way tab should behave in the search panel, this is now easier to address. Here's the behavior we agreed on:
- when the last one-off button is highlighted, pressing <tab> or <down> should select the search setting (or first open search item if there's any).
- when the search setting item is highlighted, pressing <down> should clear the selection. <tab> should move the focus out of the panel.
Summary: the "change search settings" button cannot be selected via the keyboard → the "Change Search Settings" button and the open search items cannot be used via the keyboard
Flags: qe-verify+
Flags: firefox-backlog+
Florian, can you estimate this?
Flags: needinfo?(florian)
Points: --- → 5
Flags: needinfo?(florian)
Assignee: nobody → florian
Status: NEW → ASSIGNED
Iteration: --- → 38.1 - 26 Jan
Depends on: 1124904
Iteration: 38.1 - 26 Jan → 38.2 - 9 Feb
Attached patch PatchSplinter Review
Forgot to hg add a file in attachment 8558028 [details] [diff] [review], pushed to try again: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f3c578b1549
Attachment #8558028 - Attachment is obsolete: true
Attachment #8558028 - Flags: review?(dtownsend)
Attachment #8558032 - Flags: review?(dtownsend)
Attachment #8558032 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/integration/fx-team/rev/ab00a9cbd01b
Flags: in-testsuite+
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ab00a9cbd01b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Comment on attachment 8558032 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1088660
[User impact if declined]: impossible to add open search engines with only the keyboard.
[Describe test coverage new/current, TreeHerder]: this patch contains tests, added above the tests landed in bug 1124900.
[Risks and why]: I would like to have this shipping soon, but I think it's too risky for beta at this point. This depends on the refactoring in bug 1124904.
[String/UUID change made/needed]: none.
Attachment #8558032 - Flags: approval-mozilla-aurora?
There's a fair amount of code change required for this fix. Can this be verified on Nightly before uplifting to Aurora?
Flags: needinfo?(kjozwiak)
Flags: needinfo?(florian)
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #10)
> There's a fair amount of code change required for this fix. Can this be
> verified on Nightly before uplifting to Aurora?

Seems totally reasonable to me, we still have time to land in aurora.
Flags: needinfo?(florian)
Went through verification using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-02-09-03-02-04-mozilla-central/

Test Cases:
===========

- ensured that you could still go through the listed suggestions terms using the up/down arrows
- ensured that you can select every item in the search bar using the up/down arrows (suggestions, one-click search engines, change search settings button etc..)
- ensured that you can only select the one-click search engines and the search url text box when using tab
- ensured that once you land on the "Change Search Settings" button, pressing "Enter" opens the "Search" preferences without any issues
- ensured that you can select and press "Enter" on "one-click" search engines
- ensured that you can select and press "Enter" on "one-click" search engines and search suggestions while using the arrow keys
- ensured that you can select the "Change Search Settings" button when either going through the list from the top or the bottom

OS's Used:
==========

- Win 8.1 x64
- OSX 10.10.2
- Ubuntu 14.04.1

possible issues:
================

- when selecting the "Change Search Settings" button with the keyboard on Windows/Linux, the button isn't highlighted making it very difficult to see if it has been selected. On OSX, you can tell the button has gotten a bit darker when it's selected. I logged into my Win machine remotely and noticed the same thing happening so I don't think it's related to the VMs.

- when pressing tab, once you hit the "Change Search Settings", you'll escape the search toolbar and continue through the other text boxes on current page. I'm not sure if this is intended behavior or the user should be confined to the search toolbar if he's already in it and pressing tab. Once the user does "escape" the search toolbar, he can eventually return after pressing tab and going through the entire page. I don't think this is a real issue but just double checking.
Flags: needinfo?(kjozwiak) → needinfo?(florian)
(In reply to Kamil Jozwiak [:kjozwiak] from comment #12)

Thanks!

> - when selecting the "Change Search Settings" button with the keyboard on
> Windows/Linux, the button isn't highlighted making it very difficult to see
> if it has been selected.

Looks like I forgot to do on Windows/Linux the CSS changes I did on Mac at https://hg.mozilla.org/mozilla-central/rev/ab00a9cbd01b#l6.1

Patch coming soon.

> - when pressing tab, once you hit the "Change Search Settings", you'll
> escape the search toolbar and continue through the other text boxes on
> current page.

I think that's the expected behavior since bug 1104142.
Flags: needinfo?(florian)
Adding this trivial patch in the same bug as this is not marked verified yet, and I'll fold the 2 patches together to request aurora approval.
Attachment #8562752 - Flags: review?(dtownsend)
Attachment #8562752 - Flags: review?(dtownsend) → review+
Went through verification using the following build:
* http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2015-02-17-03-02-13-mozilla-central/

- Went through the test cases listed in comment # 12
- ensured that the CSS transition occurs on OSX/Win/Linux
- ensured that "Change Search Settings" changes correctly when using the arrow keys to select
- ensured that "Change Search Settings" changes correctly when using the tab key to select
Comment on attachment 8558032 [details] [diff] [review]
Patch

Now that this has been verified, Aurora+
Attachment #8558032 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using Firefox 37 beta 1 under Ubuntu 12.04 LTS 32-bit, Windows 7 64-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.