Crash when accessing subfolders of folder that was renamed

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: jim-patterson, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have encountered a crash when renaming a folder that has subfolders. The
folder is under Local Folders, and has several subfolders. If I rename the
folder e.g. 'Family' -> 'Family&Friends', it repositions farther down on the
screen and the subfolders disappear. I then scroll down to locate it again. It's
showing as open but nothing is visible below it. I click on the down-arrow icon
to "close" it, then click on it again (now a right-arrow) to open it. At this
point, it crashes.

Good news is that the renaming worked just fine. It seems to be an in-memory
confusion only.

Comment 1

16 years ago
Reporter: In the future, please include the BuildID in your bug reports.
I saw no crash after following your steps on build 2001111503, Win98. But since
I don't use Linux and noone else has confirmed, it is up to you to verify if
this really a "worksforme". So, repeat exactly the steps to reproduce the bug,
then report the results here. You may wish to try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip 
(as always, be sure to delete your old Mozilla directory before installing the
new one) , particularly if your build is more than a month old (e.g. 20011117).
(Reporter)

Comment 2

16 years ago
It doesn't happen for me now either after rebuilding with today's source (or
with two downloads, one on Windows XP and the other Linux). Perhaps I just
grabbed the source at a bad time; next time I'll confirm first with a downloaded
build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
marking verified as worksforme based on reporter's last comment
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.