[Windows] Firefox hangs after sharing application

RESOLVED WORKSFORME

Status

()

P2
normal
Rank:
29
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8526042 [details]
log file

Reproducible on:
Firefox 34 beta 10 (Build ID: 20141117202603):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Firefox 34 beta 10 (Build ID: 20141119030200):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

Steps to reproduce:
1. Launch Firefox.
2. Navigate to about:config, search for 'media.getusermedia.screensharing.allowed_domains' and add people.mozilla.org
3. Restart Firefox.
4. Navigate to https://people.mozilla.org/~fqueze2/webrtc/ff_gum_test.html
5. Click on Application button and share any given app.

Expected results: The selected application is successfully shared.

Actual results: After ~20 minutes, Firefox is unresponsive.

Note:
1. Reproducible on Windows 8.1 64-bit; Not reproducible on Mac OS X 10.9.5 nor Ubuntu 14.04 32-bit.
2. After the hang, a notification with Aero disabling is displayed and the mouse pointer is constantly shaking after sharing an application. Reproducible only on Windows 7 64-bit, not with Windows 8.1 64-bit.
3. Attached is the .log file.
4. After the hang, Firefox crashes if:
   1. Click the url bar and press enter or click on the Refresh button multiple times.
   2. Share another application.

Crash reports:
bp-aa04d439-da18-40df-82ea-cfbe62141120
bp-f5c167ce-ab75-470f-b1b5-6823a2141120

4.1. With latest Nightly and e10s enabled, a tab crash is displayed instead of a crash.
(Reporter)

Updated

4 years ago
Blocks: 1036653
Does this still happen with Nightly?
backlog: --- → webRTC+
Rank: 29
Flags: needinfo?(alexandra.lucinet)
Priority: -- → P2
(Reporter)

Comment 2

4 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #1)
> Does this still happen with Nightly?

No, couldn't reproduce with latest 41.0a1 (from 2015-06-21) e10s on/off, under Windows 7 64-bit nor Windows 8.1 64-bit.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(alexandra.lucinet)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.