Bug 1102532 (e10s-wot)

[e10s] "Web of Trust - WOT" add-on tracking bug for e10s issues

RESOLVED INVALID

Status

()

Core
XPConnect
RESOLVED INVALID
4 years ago
10 months ago

People

(Reporter: cpeterson, Unassigned, NeedInfo)

Tracking

({meta})

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [amo-author-notified] [sitewait], URL)

Comment hidden (empty)

Updated

4 years ago
Keywords: meta
Assignee: Gabor Krizsanits
Link to add-on: AMO
Add-on ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}
How well does it work?: 50%
Steps to reproduce working features:
- yahoo does not work (WOT icon does not show up in e10s/non-e10s and icon is broken in google chrome)
- google is broken in e10s except when the searchbar is used for the search, then it works for some reason
(No categories are known yet. Not good situation. wot.js:802:17) on the console
- on facebook and in some other cases as well the js console is full of unsafe CPOW warnings

Steps to reproduce broken features:
- bing fully works

Any obvious performance problems? Not really. I guess some of our optimizations helped (or the add-on was updated?), since I detect no more lag on facebook, the add-on seem to work quite smoothly

Chromium version: The chromium version does not work on yahoo (see above) but other than that it exists and works the same way.

Comment 2

3 years ago
Contacted the Dev on AMO.
Whiteboard: [amo-author-notified]

Comment 3

3 years ago
Recontacted as they've had several updates since.
Whiteboard: [amo-author-notified] → [amo-author-notified] [sitewait]

Comment 4

2 years ago
Reproduced with Ubuntu 14.04 (Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0).
Browser window shows "unsafe CPOW usage" for google.com.
Ubuntu terminal shows "wot_search.watch: failed with TypeError: Argument 1 of MutationObserver.observe does not implement interface Node."

Comment 5

2 years ago
With WOT 20151208 on Firefox 48 Beta 6 with e10's enabled, WOT Icons no longer appear to the right of Search results.

Comment 6

2 years ago
I can confirm Bud's report. For, on Firefox 49.04b on Wincdows, and on an slightly earlier, non-beta version on Linux Mint, WOT (version 20151208) does not display its icons in search results, on Reddit, or, indeed, quite possibly, anywhere. And disabling e10s fixes the problem.

Comment 7

2 years ago
Win 7 Pro.64 bit

On further investigation it seems to be search engine specific.
For some reason the only one it works with here is DuckDuckGo, still not with Google, Bing, Startpage or Ixquick.

Comment 8

2 years ago
@On 49.0b5

Comment 9

2 years ago
Currently, WOT only supports final releases of Firefox, which means it doesn't support any of the pre-releases versions (Nightly-Aurora-Beta).
If you do wish to run WOT on any of the pre-releases versions, you would have to disable e10s and restart Firefox.

Regardless, a new version is being worked on to fully support all versions/e10s.

Comment 10

2 years ago
(In reply to Against Intuition, Inc. from comment #9)
> Currently, WOT only supports final releases of Firefox, which means it
> doesn't support any of the pre-releases versions (Nightly-Aurora-Beta).
> If you do wish to run WOT on any of the pre-releases versions, you would
> have to disable e10s and restart Firefox.
> 
> Regardless, a new version is being worked on to fully support all
> versions/e10s.

Testing can be good for Firefox and W.O.T, so extension working with e10s would give more possibilities for testers, ATM I can't test e10s on Nightly, since WOT is essential extension, more than sure not only for me.

Comment 11

2 years ago
(In reply to Against Intuition, Inc. from comment #9)
> Currently, WOT only supports final releases of Firefox, which means it
> doesn't support any of the pre-releases versions (Nightly-Aurora-Beta).
> If you do wish to run WOT on any of the pre-releases versions, you would
> have to disable e10s and restart Firefox
Well that's obvious and why we're concerned.
> 
> Regardless, a new version is being worked on to fully support all
> versions/e10s.

Fx48 is a final release, e10's activation is either done(or not)by Mozilla or the user, you guys have been aware of this for a couple of months, https://www.mywot.com/en/forum/66816-firefox-e10s good to hear that a compatible version's on the way as with e10's enabled Firefox is the only 'major' browser that WOT doesn't work with.
Tested and can see difference with e10s is enabled.
http://www.bing.com/search?q=candy&qs=n&form=QBLH&pq=candy&sc=8-5&sp=-1&sk=&cvid=3AC6E724C6494055B821A1E1371EAADB
When e10s is enabled the WOT icon is not displayed next to the links, turn e10s off and the links are displayed.
There are no CPOW messages.
Also interpositon (shim) was at true/false with e10s enabled but there was no difference icon still not displayed.
WOT 20151208
Version 	51.0a2
Build ID 	20160929004005
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:51.0) Gecko/20100101 Firefox/51.0
"ni" me if addtional info/test is needed.
Flags: needinfo?(sescalante)

Comment 13

2 years ago
Would it be reasonable to ask someone to post something on WOT's forum about this? I tried to do that just now but repeatedly received what the page called 'a validation error'. The URL is https://www.mywot.com/en/node/add/forum (I think; WOT don't make it easy to find or identify their forum!).

Comment 14

10 months ago
Not sure what the plan is with this add-on, but given the move to WebExtensions, assuming that a more relevant bug on that would be useful.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.