If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Email][Signature] Email signature preview does not update in initial setup.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: jrburke)

Tracking

({regression})

unspecified
2.2 S1 (5dec)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8526388 [details]
logcat-email.txt

Description:
After logging in to an email account, the user is given several email settings to configure before being taken to that account's inbox.  If the user modifies the email signature here, the signature preview does not update.

Notes
-The new signature is still saved and applied to composed emails properly.
-This issue does not occur if the email signature is modified in the account settings after the user has already gone to the inbox.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141120040205
2) Connect to WiFi or Cellular Data
3) Launch the Email app.
4) Sign in to an email account
5) Change the Signature in the initial account setup
  
Actual:
The email signature preview does not update after changing the signature.
  
Expected: 
The email signature preview updates properly after changing the signature.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141120040205 (Shallow Flash)
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 6/6
See attached: video clip (URL), logcat

-----------------------------------

This issue does NOT occur on Flame 2.1
Email signature preview updates properly during initial setup.

Environmental Variables:
Device: Flame 2.1 (319MB)
BuildID: 20141120001207 (Shallow Flash)
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Visible regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
This is probably from bug 1005446.
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141102105539
Gaia: 8a13593f860f863c2c9f9c1a860a39971657367c
Gecko: dc0694997f61
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141102115338
Gaia: 7fc32b16fabbe0ec33135f8864066cbde702f1c0
Gecko: cd1e1d3d9179
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 7fc32b16fabbe0ec33135f8864066cbde702f1c0
Gecko: dc0694997f61

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: 8a13593f860f863c2c9f9c1a860a39971657367c
Gecko: cd1e1d3d9179

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/8a13593f860f863c2c9f9c1a860a39971657367c...7fc32b16fabbe0ec33135f8864066cbde702f1c0

Caused by Bug 1005446 - comment 2's correct.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Broken by Bug 1005446 - James can you please take a look.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(jrburke)
(Assignee)

Comment 5

3 years ago
Created attachment 8528021 [details] [review]
GitHub pull request

Yes, this was just an overly aggressive removal of an onCardVisible update for the button text that was in the code before bug 1005446 landed.

This pull request restores that code as it was before. Fix tested on flame device, and tested both cases of the signature button showing up. In this card and off of settings_account, which already correctly has the same onCardVisible update snippet.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Flags: needinfo?(jrburke)
Attachment #8528021 - Flags: review?(bugmail)
Attachment #8528021 - Flags: review?(bugmail) → review+
(Assignee)

Comment 6

3 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/8b1926788f348880f6bb7851cb88f4770556ed7a

from pull request:
https://github.com/mozilla-b2g/gaia/pull/26429
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)

Comment 7

3 years ago
Issue is verified fixed on 2.2 flame 

On inital launch and set up of email, changing the signature is kept after editing 

Flame 2.2
Environmental Variables:
Device: Flame 2.2
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.