Namespace problem in TransforMiiX

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Mike Schiraldi, Assigned: sicking)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

17 years ago
I'm having some trouble getting Transformiix to parse a document that uses
namespaces. The attached test case outputs "[]" instead of "[foo]"

See
http://groups.google.com/groups?hl=en&th=b162e03e2cdfa928&seekm=3BF3A3EF.5DF9450D%40numerik.uni-kiel.de&frame=off
for netnews discussion.
(Reporter)

Comment 1

17 years ago
Created attachment 57916 [details]
XSL example
(Reporter)

Comment 2

17 years ago
Created attachment 57917 [details]
XML example

Comment 3

17 years ago
bug 102293 could fix this. We need to check a few landing gears for this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
we can't really fix this one fully until we resolve namespace during parsing, 
which require the new contexts. We could however work around this and make it 
work for the most common cases by setting mXPathParseContext to 
xslDocument.documentElement at the top of ::findTemplate. It's a hack and will 
not fully work, but it should cover the most common cases and i think that that 
was in effect what we used to do.

We should at least get this in better shape for the next milestone, but until 
then it might IMHO be better to concentrate our efforts on the RightThing.
Depends on: 96410, 102293

Updated

17 years ago
No longer depends on: 96410

Updated

17 years ago
Attachment #57916 - Attachment mime type: text/xsl → text/xml
Created attachment 60326 [details] [diff] [review]
workaround hack

Since the plans for the contexts has become somewhat bigger i doubt that we'll
be able to get them in before 0.9.7. So this hack-around will make us do about
the same as we used to do, which should take care of most cases.

If we still aim the contexts for 0.9.7 then just ignore the patch

Comment 6

17 years ago
Comment on attachment 60326 [details] [diff] [review]
workaround hack

OK, contexts won't make it to 0.9.7.
Suggest a text to be put up on the project page, so
we can describe the horkage in detail.
Add a XXX wallpaper to the
comment, this is not a 
solution.

Other than that, r=me
Attachment #60326 - Flags: review+
added the comment in my local tree. I suggest we put something like

"Transformiix namespace handling currently has many problems, watch bug 96410 
and bug 113611 for progress"
Assignee: kvisco → sicking
Comment on attachment 60326 [details] [diff] [review]
workaround hack

sr=jst
Attachment #60326 - Flags: superreview+
checked in, we'll close this once namespacehandling actually works. Pike, do 
you want this bug now?
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All

Updated

17 years ago
Depends on: 113611
Created attachment 87050 [details]
testcase (stylesheet)
Attachment #57916 - Attachment is obsolete: true
Attachment #57917 - Attachment is obsolete: true
Attachment #60326 - Attachment is obsolete: true
Created attachment 87051 [details]
testcase (source)
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
we didn't verify for a long time.
I really checked, so VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.