Use of uninitialised variable in nsWindow.cpp

RESOLVED FIXED in Firefox 34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil, Assigned: neil)

Tracking

({regression})

34 Branch
mozilla36
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox34 fixed, firefox35 fixed, firefox36 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Steps to reproduce:
1. Start thunderbird.exe -silent -jsconsole *
2. Evaluate fullScreen = true
3. Evaluate fullScreen = false

Expected result: Window chrome is restored

Actual result: Window chrome is still hidden

* Sorry, but Firefox's Browser Console sucks for demonstrating this.
Assignee

Comment 1

5 years ago
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8526725 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #8526725 - Flags: review?(jmathies) → review+
Assignee

Comment 2

5 years ago
Comment on attachment 8526725 [details] [diff] [review]
Proposed patch

Approval Request Comment
[Feature/regressing bug #]: 1063121
[User impact if declined]: Full screen might not work reliably
[Risks and why]: No risk
[String/UUID change made/needed]: None
Attachment #8526725 - Flags: approval-mozilla-beta?
Attachment #8526725 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/285c55e9b40d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Looks like this is a regression 34. It's too late in the cycle for anything other than a stop ship bug. Can we live with this in the 34 cycle?
Flags: needinfo?(neil)
Comment on attachment 8526725 [details] [diff] [review]
Proposed patch

I spoke with jimm and gavin on irc. Both think we need to take this. Low risk and can still make it in time for RC.
Beta+
Aurora+
Attachment #8526725 - Flags: approval-mozilla-beta?
Attachment #8526725 - Flags: approval-mozilla-beta+
Attachment #8526725 - Flags: approval-mozilla-aurora?
Attachment #8526725 - Flags: approval-mozilla-aurora+
Flags: needinfo?(neil)
You need to log in before you can comment on or make changes to this bug.