Closed Bug 1102912 Opened 8 years ago Closed 8 years ago

[Linux][Mac] Preferences->Search is not automatically updated when a new search engine is added.

Categories

(Firefox :: Search, defect)

34 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Iteration:
37.2
Tracking Status
firefox33 --- unaffected
firefox34 + wontfix
firefox35 + verified
firefox36 + verified
firefox37 + verified
firefox-esr31 --- unaffected

People

(Reporter: VarCat, Assigned: florian)

References

Details

Environment:
FF 34.11b
Build Id:20141120192249
OS:Ubuntu 14.04 x64

STR:

1. Go to Preferences-> Search.
2. Add a new search engine.

Issue:
Adding a new search engine will not update automatically the Search Engine suggestion checkbox list and the Default Search Engine dropdown list from the Preferences -> Search window.
Summary: [Linux] Preferences->Search is no automatically updated when a new search engine is added. → [Linux] Preferences->Search is not automatically updated when a new search engine is added.
This also reproduces on Mac OS X 10.9.5, but not on Windows since you need to close Preferences before you can add a new search engine.
Summary: [Linux] Preferences->Search is not automatically updated when a new search engine is added. → [Linux][Mac] Preferences->Search is not automatically updated when a new search engine is added.
This is wontfix for 34. I have tracked 35+
Flags: firefox-backlog? → firefox-backlog+
I fixed this as part of bug 1106559.

Note: when an engine is removed, the preference UI isn't updated automatically... but that's unlikely to happen, unless the user opens the preferences UI twice. Supporting engine additions was more important, as users will typically add engines from a web page that may be open alongside the pref UI.
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 1106559
Resolution: --- → FIXED
Iteration: --- → 37.2
Flags: qe-verify+
QA Contact: catalin.varga
Verified as fixed using the following environment:

Environment:
FF 35.0b5
Build Id:20141218174327
OS:Ubuntu 14.04 x64, Mac Os X 10.9.5
Verified as fixed using Developer Edition 36.0a2 and Nightly 37.0a1 2014-01-06 under Ubuntu 12.04 LTS 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.