DownThemAll! 2.0.17 doesn't work after landing patches from bug #1095439

VERIFIED FIXED

Status

defect
--
major
VERIFIED FIXED
5 years ago
2 months ago

People

(Reporter: Virtual, Assigned: nmaier)

Tracking

({addon-compat, nightly-community})

Firefox 36
x86_64
Windows 7

Firefox Tracking Flags

(firefox35 unaffected, firefox36 verified)

Details

(Whiteboard: [Fixed in DownThemAll! 2.0.18], URL)

Regression window (mozilla-inbound-win32)
Good:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1416357866/

Bad:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1416357986/

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=47faf7c36050&tochange=14a34e921e1b

Probably caused by:
Bug #1095439 - Assigning to a const variable is a syntax error



These errors are shown in Error Console:

Timestamp: 2014-11-21 16:55:45
Error: SyntaxError: invalid assignment to const Dialog
Source File: chrome://dta/content/dta/manager/manager.js
Line: 1082

Timestamp: 2014-11-21 16:55:45
Error: uncaught exception: 2147500037

Timestamp: 2014-11-21 16:55:45
Error: ReferenceError: Construct is not defined
Source File: chrome://dta/content/dta/manager/tree.js
Line: 3
[Tracking Requested - why for this release]: Regression for 1,3M users
The issue is fixed in next stable build of DownThemAll! 2.0.18.
So I'm closing this bug as FIXED.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Fixed in DownThemAll! 2.0.18]
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.