land Flare strings in Firefox 36 and enable it for all locales

RESOLVED FIXED in Firefox 36

Status

()

Firefox
Search
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Gavin, Assigned: florian)

Tracking

Trunk
Firefox 36
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(firefox34 wontfix, firefox35 wontfix, firefox36+ fixed)

Details

Attachments

(1 attachment)

We want to get this localized as soon as possible.

Maybe this is easiest to do by just landing the trunk patch, but if not we can also just land a strings-only patch.
Blocks: 1103197

Comment 1

3 years ago
can you explain what this bug is about?  is it to support localization of UI for one-off searches?

we actually really need that for bugs like 1102323 where its not all that clear that switching to yandex is what users want, and are likely want and need help in switching back to their previous search engine.

whats the planned schedule for this?
(Assignee)

Comment 2

3 years ago
(In reply to chris hofmann from comment #1)
> can you explain what this bug is about?  is it to support localization of UI
> for one-off searches?

Yes.

This bug is about ensuring the user-visible strings of the new UI landed for Firefox 34 in bug 1088660 land in mozilla-central in time to be localized for Firefox 36.

Currently these strings are hardcoded in a patch that landed only on mozilla-beta.

Looks like the deadline to do this is Friday this week.
There was
status-firefox34: --- → wontfix
status-firefox35: --- → wontfix
status-firefox36: --- → affected
tracking-firefox36: --- → +
The expectation is that Flare will ship to all locales in 36. As such, I am not expecting that we're going to break string freeze on 35 for these strings. It is highly preferable that these strings land on m-c before the merge on Friday to keep things simple.
Flags: needinfo?(florian)
(Assignee)

Comment 5

3 years ago
Created attachment 8529310 [details] [diff] [review]
Patch
Assignee: nobody → florian
Flags: needinfo?(florian)
Attachment #8529310 - Flags: review?(felipc)
(Assignee)

Comment 6

3 years ago
Philipp, while making the strings localizables, I replaced "Add more search providers…" with "Add more search engines…" at the bottom of the preferences pane because I remember madhava saying "providers" is technical jargon we shouldn't use anymore. Needinfo'ing you just to double-check this was the right thing to do. Thanks!
Flags: needinfo?(philipp)
Comment on attachment 8529310 [details] [diff] [review]
Patch

Review of attachment 8529310 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/profile/firefox.js
@@ +421,5 @@
>  
>  // enable search suggestions by default
>  pref("browser.search.suggest.enabled", true);
>  
> +pref("browser.search.showOneOffButtons", true);

it's not to my knowledge that we'll be switching everyone in 36 to the new UI. Can you double check that? At least, if that's true, it probably shouldn't happen in this bug which is about making the strings localizable.
Attachment #8529310 - Flags: review?(felipc) → review+
Comment on attachment 8529310 [details] [diff] [review]
Patch

Review of attachment 8529310 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/locales/en-US/chrome/browser/preferences/search.dtd
@@ +3,5 @@
> +   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
> +
> +<!ENTITY defaultSearchEngine.label             "Default Search Engine">
> +
> +<!ENTITY chooseYourDefaultSearchEngine.label   "Choose your default search engine. &brandShortName; uses it in the location bar, search bar, and start pages.">

Why plural ("start pages")?
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> Philipp, while making the strings localizables, I replaced "Add more search
> providers…" with "Add more search engines…" at the bottom of the preferences
> pane because I remember madhava saying "providers" is technical jargon we
> shouldn't use anymore. Needinfo'ing you just to double-check this was the
> right thing to do. Thanks!

Yes, good call!


(In reply to Francesco Lodolo [:flod] from comment #8)
> Why plural ("start pages")?

Presumably because there are two pages where it's used (about:home and about:newtab).
However, that seems to be a distinction that will cause more confusion than clarity, so let's go with singular (… search bar, and the start page).
Flags: needinfo?(philipp)
(Assignee)

Comment 10

3 years ago
(In reply to :Felipe Gomes (behind on reviews until the end of the week) from comment #7)

> > +pref("browser.search.showOneOffButtons", true);
> 
> it's not to my knowledge that we'll be switching everyone in 36 to the new
> UI. Can you double check that? At least, if that's true, it probably
> shouldn't happen in this bug which is about making the strings localizable.

To my knowledge the only reason why flare is disabled for non-en-US is that we couldn't make it localizable for 34. I actually had the same doubt as you, so I asked Gavin on IRC yesterday to be fully sure:

21:17:17 - flo-retina: gavin: on 36, the flare UI should be enabled for all locales by default, right?
21:21:57 - gavin: flo-retina: let's say yes for now

I can split that change to a separate changeset is that makes you feel better :-).
Oops, I added a »the« to that sentence where there shouldn't be one. It should read:

Nightly uses it in the location bar, search bar, and start page.
(Assignee)

Comment 12

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/474e1bda6a0f
https://hg.mozilla.org/integration/fx-team/rev/c9350d69c4bc
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/474e1bda6a0f
https://hg.mozilla.org/mozilla-central/rev/c9350d69c4bc
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox36: affected → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
Hi Florian, can you assign a point value.
Iteration: --- → 37.1
Flags: qe-verify?
Flags: needinfo?(florian)
Flags: firefox-backlog+
Summary: land Flare strings in Firefox 36 → land Flare strings in Firefox 36 and enable it for all locales
(Assignee)

Updated

3 years ago
Points: --- → 3
Flags: needinfo?(florian)
Flags: qe-verify? → qe-verify-
(Assignee)

Comment 15

3 years ago
We are taking this in 35 too, see bug 1107278.
See Also: → bug 1107278
Duplicate of this bug: 1106607
(Assignee)

Updated

3 years ago
Blocks: 1119250
You need to log in before you can comment on or make changes to this bug.