Build failure on Windows when USE_D2D1_1 is not defined

RESOLVED DUPLICATE of bug 1103868

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1103868
4 years ago
3 months ago

People

(Reporter: avih, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8527137 [details] [diff] [review]
bug-d2d11.patch

I _think_ the title describes the issue correctly, but feel free to fix it otherwise.

I'm building on Windows 7 with VS2010 and DXSDK June 2010. I know I should update the configuration but I still feel this is a real bug which should be fixed regardless.

The first error I get is:

gfx/thebes/gfxWindowsPlatform.cpp(617) : error C2039: 'SupportsD2D1' : is not a member of 'mozilla::gfx::Factory'

I Made it available and returning false, and then it failed, IIRC, on mD2D1Device not a member at Factory::D2DCleanup(), so I #ifdef USE_D2D1_1 these parts.

I ended up with the attached patch which allows me to complete the build successfully.

Matt thinks the patch approach is incorrect and instead it shouldn't try to call SupportsD2D1 if USE_D2D1_1 is not defined, but I'd leave the details to you.

Note that the patch also includes a probably-unrelated modification to common/platform.h where I included 3 more headers due to apparently ANGLE incorrect build config (thanks to vladv for the help on this).
(Reporter)

Updated

4 years ago
Summary: Build failure on Windows when D2D 1.1 is not available at compile time → Build failure on Windows when USE_D2D1_1 is not defined
(Reporter)

Comment 1

4 years ago
The issues here were fixed at bug 1103868 and possibly also with bug 1097803.

Missing definition for USE_D2D1_1 no longer breaks the build.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1103868

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.