Closed Bug 1103329 Opened 5 years ago Closed 5 years ago

Scrollbar flickers and browser slows down

Categories

(Web Compatibility :: Mobile, defect)

Firefox 33
ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bobleehk, Unassigned)

References

()

Details

(Whiteboard: [country-us] [js] [notcontactready])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Use Firefox 33.1 for Android to browse https://docs.oracle.com/cd/B28359_01/server.111/b28286/statements_9016.htm

Device is Asus ME372CL


Actual results:

Vertical scrollbar keeps flickering, and the menu bar showing the page number occasionally scrambles  
The browser takes much more time to handle links clicking, going to previous page, and basically everything other than scrolling and showing the Firefox menu.


Expected results:

No flicker!
Can you try out Nightly (http://nightly.mozilla.org) for Android and report back if that is working for you?

Also, are you able to record a video of the problem and attach it to this bug?
Flags: needinfo?(bobleehk)
Also, was the Firefox you are using downloaded off of Google Play? If not, please make sure you are running the x86 version of Firefox for Intel based Android devices: http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/33.1/android-x86/multi/fennec-33.1.multi.android-i386.apk
I'm able to reproduce the flickering scrollbar on nightly on a nexus4. I'm guessing there is some script running constantly on the page that is resizing it back and forth between two values which is making the scrollbar flicker. This would also explain the other symptoms described in comment 0 if the CPU(s) are being hogged by the script.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(bobleehk)
Confirmed that this doesn't appear to be a gecko issue. The page is running JS that is causing the scrollable area of the page to oscillate between two values.
Component: Graphics, Panning and Zooming → Mobile
OS: Windows 7 → Android
Product: Firefox for Android → Tech Evangelism
Hardware: x86_64 → ARM
The scrollbar is flickering until it disappears on Firefox Android device (35)
Note that 
1. I can't reproduce this on a Firefox OS Flame device. So it's really dependent of the Android context.
2. I can't reproduce when faking Firefox Android UA on desktop.

In the script codemirror.js, there are 79 occurences of the term scrollbar. Maybe unrelated, but still could be something to explore.

Also an article from the creator of the script.
http://marijnhaverbeke.nl/blog/a-pathological-scrolling-model.html

Another source is the script layers087.js coming this time from s7.addthis.com

Maybe Hallvord has a better idea.
Flags: needinfo?(hsteen)
Whiteboard: [country-us] → [country-us] [js]
This has something to do with the media queries in https://docs.oracle.com/cd/B28359_01/nav/css/html5.css

Removing the block that starts 

@media only screen and (min-width: 175px) {

will fix it. But it also takes a bit of scripting to make it happen..
TBC
Actually, this is all the CSS you need:

@media only screen and (min-width: 175px) {
    #NAV {
    position:relative !important;
    }
}
Flags: needinfo?(hsteen)
Whiteboard: [country-us] [js] → [country-us] [js] [contactready]
I'd like to understand this better before we reach out.. (It's a very slow and finicky thing to debug though - the page typically hangs for seconds while loading.)
Flags: needinfo?(hsteen)
Whiteboard: [country-us] [js] [contactready] → [country-us] [js] [notcontactready]
Retested in Firefox 38 (current Beta) on what's admittedly a more powerful phone (Moto X) - the page seems to work smoothly now.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(hsteen)
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.