Page content not always updated on FTP "LIST" request




Networking: FTP
17 years ago
16 years ago


(Reporter: Benjamin Mucci, Assigned: bbaetz)



Firefox Tracking Flags

(Not tracked)




17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011115
BuildID:    2001111504

Try to access any user account via FTP with Moz. Result: The directory doesn't load.

The log server returns:
Nov 15 19:50:03 linux proftpd[32265]: ([])
- FTP no transfer timeout, disconnected. asks for the password but directory doesn't load..

BTW loggin in http ( works great.

Reproducible: Always

Comment 1

17 years ago
WFM with both 0.9.5 and current CVS on linux, using wu-ftpd to localhost.

Can you get a packet trace (removing your password), and attach it to the bug?

What do you mean by douesn't load? Does a blank page come up, or does it just
stay at the previous page?

There was a change recently to make ftp://[optionalUser@]host/ stay in teh login
directory the server gives, rather than change to /, but thats unlikely to cause

Comment 2

17 years ago
Finally the problem isn't related to user/password...
-> Change summary

> What do you mean by douesn't load?

Previous page stays. But status changes to Beginning FTP transaction... to 
Document: Done (xx).. After lot of *retry* the *right content* is sometime 
displayed... also:

1) I get sometime "Data connection error: Broken pipe" alert... Packet trace 
return "425 Datacone" (Possible??) (BTW: Never get this with anonymous access, 
only on account login)
2) Sometime when clicking on link /refresh /reenter the ftp address nothing 
happens... but even if Moz doesn't change the content, every commands appear in 
the trace... (except on "Broken pipe" - I think..?). But (here is the weird part) 
if I let the browser window open, the *nodisplayed request* are delayed and 
displayed after a while. It's like a BIG lag... Here it's probably the 
explanation: on repeated requests Moz open multiples sessions

inetd FTP connections:
  941 2m23s  proftpd: ftp - anonymous/ IDLE
  942 2m17s  proftpd: ftp - anonymous/ IDLE
  944 2m13s  proftpd: ftp - anonymous/ IDLE
   -  -      3 users

Also sometime the directory listing isn't displayed but the "Index of ftp://
ftp.." and the two horzital lines are. But on direct URL request -> file 

Obviously everything works great with NN4.7 or other FTP client...
Summary: doesn't work. → Page content not always updated on FTP "LIST" request

Comment 3

17 years ago
Can you attach a full packet trace for the anonymous user?. On unix/windows, you
can use ethereal. Don't use tcpdum unless you set it to capture the entire
packet's contents.

Are you behind a filewall/NAT of some sort? I know os2 servers have problems
with the way we do things, but that doesn't explain why it sometimes works.

reload/shift-reload for a dir listing doesn't do the right thing at the moment -
thats a separate bug?

Did earlier mozilla versions work?

Comment 4

17 years ago
Bradley: I tried on 3 computers with MacOS 8.6 with same result. From inside the
LAN and outside (modem). I can reproduce with an old build 2001091303 under
Win98 from LAN -> Sometime dir content isn't diplayed.

-> All/All/Normal
Severity: major → normal
OS: Mac System 8.6 → All
Hardware: Macintosh → All

Comment 5

16 years ago
I wonder if the patch on bug 110241 will help here.

Comment 6

16 years ago
I've made a couple of changes recently which may help this sort of problem. This
may just be the double PASV thing, and I think I have an idea on how to fix that.

Marking dependancy, although I'm not really sure.
Depends on: 123592
Target Milestone: --- → mozilla1.0

Comment 7

16 years ago
WFM. Closing it. 
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
VERIFIED: per reporter.
General feature is working in Mozilla 1.1 functionals as well.
You need to log in before you can comment on or make changes to this bug.