Closed Bug 1103966 Opened 5 years ago Closed 5 years ago

Intermittent ts_paint_cold | application crashed [unknown top frame][@ js::AutoCompartment::AutoCompartment(js::ExclusiveContext *,JSObject *)][@ ntdll.dll + 0x32239]

Categories

(Core :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37
Tracking Status
firefox35 --- unaffected
firefox36 --- fixed
firefox37 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: cbook, Assigned: mak)

References

()

Details

(Keywords: intermittent-failure)

Windows 7 32-bit mozilla-inbound talos xperf

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=4149448&repo=mozilla-inbound

02:39:45 INFO - PROCESS-CRASH | ts_paint_cold | application crashed [unknown top frame]
02:39:45 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmppyizj6\profile\minidumps\a0f039ce-186d-4aa0-ae57-085641bd70bb.dmp
02:39:45 INFO - stderr from minidump_stackwalk:
02:39:45 INFO - 2014-11-24 02:39:45: minidump_processor.cc:264: INFO: Processing minidump in file c:\users\cltbld\appdata\local\temp\tmppyizj6\profile\minidumps\a0f039ce-186d-4aa0-ae57-085641bd70bb.dmp
02:39:45 INFO - cygwin warning:
02:39:45 INFO - MS-DOS style path detected: c:\users\cltbld\appdata\local\temp\tmppyizj6\profile\minidumps\a0f039ce-186d-4aa0-ae57-085641bd70bb.dmp
02:39:45 INFO - Preferred POSIX equivalent is: /cygdrive/c/users/cltbld/appdata/local/temp/tmppyizj6/profile/minidumps/a0f039ce-186d-4aa0-ae57-085641bd70bb.dmp
02:39:45 INFO - CYGWIN environment variable option "nodosfilewarning" turns off this warning.
02:39:45 INFO - Consult the user's guide for more details about POSIX paths:
Lots of new crashes in this test all around the same time tells me there's an underlying issue at play here. Lumping the various signatures into this bug under that assumption.
Summary: Intermittent ts_paint_cold | application crashed [unknown top frame] → Intermittent ts_paint_cold | application crashed [unknown top frame][@ js::AutoCompartment::AutoCompartment(js::ExclusiveContext *,JSObject *)][@ ntdll.dll + 0x32239]
looking on fx-team you can see where this started:
https://treeherder.mozilla.org/#/jobs?repo=fx-team&searchQuery=xperf&fromchange=5ba06e4f49e8&tochange=c773c6be9270

but it is pgo only, when that ended up on m-c later that day, we see it on opt and pgo:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchQuery=xperf&fromchange=3366c0fcf9c2&tochange=c9cfa9b91dea

The problem is this looks to be showing up on a b2g-inbound merge to fx-team.  I did some more retriggers on m-c, I am not sure how to interpret these merges, maybe a sheriff can help shed some light.
Flags: needinfo?(ryanvm)
There's an inbound merge in that push too. Some suspicious-looking stuff in it too.
Flags: needinfo?(ryanvm)
That last one is from Aurora, which is odd.
yeah, we uplifted, so now we will see this on aurora.
this is showing up on the orange factor top 10 list now :(  Andrew, can you look into fixing this or can we consider backing this out?
Flags: needinfo?(continuation)
This looks like a storage issue, so I'm not going to be able to help here.  It looks like mak is already looking at this in bug 1104918.
Flags: needinfo?(continuation)
Bug 1101478 backed out on inbound. We should see this drop off on trunk once it merges to m-c later today.
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e5fce59af55
https://hg.mozilla.org/mozilla-central/rev/8e5fce59af55
Assignee: nobody → mak77
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.