bugzilla uses non-standard sql

VERIFIED DUPLICATE of bug 98304

Status

()

enhancement
VERIFIED DUPLICATE of bug 98304
21 years ago
7 years ago

People

(Reporter: jay, Assigned: ian)

Tracking

Details

Reporter

Description

21 years ago
bugzilla cannot be easily port to non-mysql databases such as postgress or
oracle.  while things like bitint and tinytext are trivial to port; enum,
timestamp, and datetime may not be easy.

is there anyway to start moving the perl and sql parts towards sql92?

Comment 1

21 years ago
Submit some patches?

I freely admit I am not much of an SQL expert.  I've figured out how to use
MySQL, that's all.

If you submit some patches that change the use to be more standards-like, that
would be great.

Meanwhile, though, I am not really very upset at the idea of requiring MySQL.

Comment 2

21 years ago
Setting all current Open/Normal to M4.

Comment 3

21 years ago
Clearing "M" field since Webtools product is not used for 5.0 specific project
bug metrics and will mess up our queries on milestones.

Comment 4

21 years ago
some things need to be done to initally start any porting process.  the first is
to implement bug/enhancement #1103, use DBI instead of mysql.pm.  this has other
advantages in that mysql.pm is deprecated in favor of DBI.

the next inital step is to break apart the make*.sh scripts.  ideally, each
script would have the creation routines and the mozilla specific values
separated out.  a sub-directory structure would be handy too.  if i may suggest:

bugzilla-root/
    database/
        mozilla-specific/
           fillcomponenttable.sh
           etc....
        test-database/
           fillcomponenttable.sh
           etc....
        mysql/
           makecomponenttable.sh
           etc....
        oracle/
           ......

Comment 5

21 years ago
Reassigning to dmose@mozilla.org, who now has front-line responsibility for
all Bonsai and Bugzilla bugs.

Comment 6

21 years ago
Reassigning back to me.  That stuff about me no longer being the front-line
person responsible for Bugzilla and Bonsai turned out to be short-lived.
Please pardon our confusion, and I'm very sorry about the spam.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 7

20 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW

Comment 8

19 years ago
God Save DBI
Assignee: tara → cyeh
Depends on: 1103

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
QA Contact: matty
Whiteboard: 3.0
Moving to real milestones...
Whiteboard: 3.0
Target Milestone: --- → Bugzilla 3.0
Assignee

Comment 10

19 years ago
Taking all Bugzilla 3.0 bugs -- congratulations to MattyT for the triage, it
really was spot on. Note: I may end up pushing some of these bugs back to 3.2,
we'll see. However, I believe all these bugs should just fall out of the 
redesign. Let's hope I'm right!

(Note: I'm also resetting the priority field to "---" so that I can retriage any
that I consider important or likely to be dropped.)
Assignee: cyeh → ian
Status: ASSIGNED → NEW
Component: Bugzilla → Bugzilla 3
Priority: P2 → --
The Bugzilla 3 component is going away.  We're going to depend on the Milestones 
for this.  At the time this component was created, we didn't have milestones for 
Bugzilla.
Component: Bugzilla 3 → Bugzilla
Severity: normal → enhancement
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
The newer PostgreSQL bug is doing most of this.

*** This bug has been marked as a duplicate of 98304 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 3.0 → ---

Comment 13

17 years ago
Verified duplicate
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.