Table elements appear twice

VERIFIED DUPLICATE of bug 101148

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 101148
16 years ago
16 years ago

People

(Reporter: RawknChrub, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I've only noticed this bug in a bulletin board system of which I'm an
administrator. Obviously no one here wants to sign up and find an applicable
post, so the URL listed is an example page which illustrates the problem.

Certain table elements appear twice when the page is rendered. You'll notice
this is the signature for the user "Necksnappa." I can't find anything in the
page's source which would cause this, and my unfortunate friends who use IE
report that the page renders correctly in that "browser." Another user of our
system uses Mozilla for Windows, and reports that he sees the same error.

I also tried using the applicable DOCTYPE tags to activate standards layout
mode, but the result was the same.

Comment 1

16 years ago
I dont see any double rendering in the given URL. Works for me in latest build 
ID : 2001111408. Reporter can you check it in the new builds and reopen this if 
you can still reproduce
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
Using Build 2001111821 (linux i386), I still see the same problem. As previously
stated, this is a page taken from a message board I help admin. In my browser
window, I see the signature from the first post on the page (by the user
Necksnappa) appear twice. I first see the user's IP (on the right-hand side),
followed by an HR tag, and then his signature.

I apologize for not thinking of this in my original post, but I've made
available a JPG which shows exactly what I'm seeing. It can be found at:

http://c359815-d.decatur1.il.home.com:3703/bugzilla.jpg

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

16 years ago
I think I've found a more specific cause for this problem. After using a Windows
machine and viewing the same pages with IE and Mozilla, it seems that the
signatures which appear twice all use "glowing" text.

Specifically, a statement similar to this appears in the TABLE tags ...
  style="filter:glow(color=red, strength=2)"

This solves my forum problems; I'll filter out statements such as the above for
visitors not using IE. I dunno if the best way to fix this problem is to
actually support glowing text (arguably it's annoying, and not what I'd call an
important feature to have ready by 1.0).

Comment 4

16 years ago
I've experienced the same thing:

http://preview.watters.com/catalog.x?c=1&sc=1

...pretty straightforward HTML, and no duplication in the HTML code.  Verified
that IE renders it properly (well, without doubling ;^)

Actually spotted while using galeon, packaged for debian/unstable, using Mozilla
0.96 as renderer.  I viewed RawknChrub's example page, and experienced the same
 render bug.  Mail me at ramses0@yahoo.com if you need a screenshot (it's
exactly the same is Rawkn's)

Comment 5

16 years ago
Created attachment 62772 [details]
Testcase

The testcase contains two tables. The second table does NOT have <tr> and <td>
tags (the first does). Both tables are contained in a <font> tag. See the
testcase for more information.

I also briefly looked at http://preview.watters.com/catalog.x?c=1&sc=1. This
contains multiple tables in a <font> tag. One of these tables is followed by a
<form> and <input> before starting the <tr><td>.

Using 2001122608 Linux

Comment 6

16 years ago
Marking new, although I'm not sure if this should be moved to Layout.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 7

16 years ago
*** Bug 118300 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Dup of bug 101148 .

Comment 9

16 years ago
agreed, marking dupe

*** This bug has been marked as a duplicate of 101148 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 10

16 years ago
 Verified dupe.
You need to log in before you can comment on or make changes to this bug.