[System Lockscreen]The lockscreen slider will not reset when holding it in place and pressing the power button

VERIFIED FIXED in 2.2 S3 (9jan)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: cnelson, Assigned: gweng)

Tracking

({regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

()

Attachments

(4 attachments)

Reporter

Description

5 years ago
Posted file log.txt
When the user holds the lockscreen slider into place and then presses the power button, the slider will fail to reset.  
   
Repro Steps:
1) Update a Flame device to BuildID: 20141121040204
2) With the Flame locked, press the power button to bring up the lockscreen.
3) Slide the lockscreen slider to one side and hold it there.
4) Press the power button to put the phone to sleep.
5) Press the power button again to wake the phone and bring up the lockscreen.
6) Notice the lockscreen slider will fail to reset.
  
Actual:
The lockscreen slider will not reset when holding it in place and pressing the power button
  
Expected: 
The slider will reset to its default position when waking the  Flame up.
  
Environmental Variables:
Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Notes: This issue also occurs on Flame 2.2 full flash. This bug fails verification of bug 1094829.
  
Repro frequency: 100%
See attached: logcat, video clip https://www.youtube.com/watch?v=utvEu91Xlyo
Flags: needinfo?(dharris)
Reporter

Comment 1

5 years ago
This issue does not occur on Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash).

The slider will reset to its default position when waking the Flame up.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Reporter

Updated

5 years ago
Blocks: 1094829
This bug was written during the verification process of bug 1094829. Nominating to block on this issue, as it was blocked in bug 1094829. Not requesting a regression window at this time due to there being patches already landed for this issue, indicating that the cause may have already been found
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Keywords: regression

Comment 3

5 years ago
Triage: regression. blocking.
Assignee: nobody → gweng
blocking-b2g: 2.2? → 2.2+
Posted file Patch
Fixed:

1. Route the patch from slideshow to sliderestore when screen is off, so that the case resolved.

2. Change the condition to transfer from sliderestore to slideshow: only when the screen is on, it would do the transferring. So that we can avoid unconditional transferring, which cause an infinite loop.
Attachment #8541376 - Flags: review?(timdream)
master: https://github.com/mozilla-b2g/gaia/commit/04d5b8dd414307c335aae08b71d2ba3992f3f058
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Unfortunately Bug 1097994 nullized this bug. The root cause is it changed the routes to another path while there is secure app, so I need to re-patch this to follow the new routing rule.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Posted file Patch rev2
Fixed: routing is not the only issue. Secure app closing in fact should be invoked via two types of events: secure-appterminated and secure-appclosing. The previous one is for 'hard kill' and the later one is 'soft kill'. This differs since people expect to have different behaviors when user presses the home or power button.
Attachment #8544944 - Flags: review?(timdream)
As a conclusion: patch add one more event to listen to solve the bug.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S3 (9jan)
Posted video verify.3gp
This bug has been verified as "pass" on latest build of Flame 2.2,Nexus5 2.2 by the STR in comment 0.

Actually result:The slider will reset to its default position when waking the Flame up.
Reproduce rate: 0/10
See attachment: verify.3gp

Device: Flame 2.2 (pass):
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.195343
Firmware Date          Wed Jul  1 19:53:55 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 (pass):
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150701.195806
Firmware Date          Wed Jul  1 19:58:26 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.