[e10s] Developer Tools is closing unexpectedly when open web page from about:newtab

RESOLVED DUPLICATE of bug 1068400

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 1068400
3 years ago
10 months ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Steps To Reproduce:
1. Open e10s windw
2. Open about:newtab
3. Open Developer Tools such as Network (Ctrl+Shift+Q)
4. Open any web page

Actual Results:
Developer Tools is closing.
I cannot verify network activities in this case.

Expected Results:
Developer Tools should be staying open.
Blocks: 875871
tracking-e10s: ? → +
(Reporter)

Comment 1

3 years ago
Regression window(fx)
Good(the dev tool is staying, though it does not function):
https://hg.mozilla.org/integration/fx-team/rev/6f233e72cb49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140826182328
Bad:
https://hg.mozilla.org/integration/fx-team/rev/f14b2654c180
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140827032228
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=6f233e72cb49&tochange=f14b2654c180

Comment 2

3 years ago
I investigated this a bit while ago and I discovered that the toolbox closes because the docshell it has attached is destroyed.

Apparently some (all?) about:* pages are rendered in the parent process. When a web page is opened a new docshell is created in a child process. This takes over the tab and the original docshell in parent process is destroyed which causes the developer tools to close if they were attached to the original docshell.
This looks like a dupe of bug 1068400
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068400
(Reporter)

Updated

3 years ago
tracking-e10s: + → ---

Updated

10 months ago
Depends on: 1327995
You need to log in before you can comment on or make changes to this bug.