Unable to connect to Firefox OS keyboard app

RESOLVED DUPLICATE of bug 1093661

Status

RESOLVED DUPLICATE of bug 1093661
4 years ago
3 months ago

People

(Reporter: zcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'm not sure when this regressed but I recall debugging the keyboard app using the old "Remote debugger".

STR:
1. Connect WebIDE to Flame
2. Manually open an app and open the keyboard

In the dropdown menu in WebIDE there is no Keyboard app option.

There is a "Built in keyboard" app but this launches the Settings app (perhaps it is following the wrong launch path).


Nightly:
BuildID: 20141124100136
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0


B2g:
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/4e67992092d9
Build-ID        20141125010836
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141125.043653
FW-Date         Tue Nov 25 04:37:04 EST 2014
Bootloader      L1TC00011880
I'll have to think about a way to handle this better...  The issue is that WebIDE is "too helpful" here, because it wants to start an app when you select it, instead of assuming it may already be open.

In any case, you can reach the keyboard via the System app and iframe selector (see bug 1100736 comment 1).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1093661

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.