Closed Bug 1104726 Opened 8 years ago Closed 8 years ago

Offscreen Async animated Element causes 60fps rendering on main thread

Categories

(Core :: Layout, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1105509

People

(Reporter: sotaro, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1104151 +++

When Async animated Element's does not have related DisplayItem, the element requests 60fps rendering on main thread. This typically seems to happen when the Element is off screen.

Throttling animation failed. AnimationPlayerCollection::CanThrottleAnimation() return false because FrameLayerBuilder::GetDedicatedLayer() return nullptr.

http://dxr.mozilla.org/mozilla-central/source/layout/style/AnimationCommon.cpp#804
http://dxr.mozilla.org/mozilla-central/source/layout/base/FrameLayerBuilder.cpp#4138
When this problem happens, Async Animation error log printout nothing about it.
See Bug 1104151 about the symptom that happened on b2g.
See Also: → 1104151
blocking-b2g: --- → 2.2?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105509
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.