If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

A long default search provider name can mess up the layout of the one-off buttons when the panel is small

VERIFIED FIXED in Firefox 34

Status

()

Firefox
Search
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: avaida, Assigned: florian)

Tracking

34 Branch
Firefox 36
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox34+ verified, firefox35+ verified, firefox36+ verified, firefox37 verified)

Details

Attachments

(1 attachment)

Reproducible on: Firefox 34.0 (build1 / 20141124205320).
Affected platform(s): Windows 7 64-bit, Windows 8 32-bit, Ubuntu 12.04 LTS 32-bit and Mac OS X 10.9.5.

STR:
1. Launch Firefox with a clean profile.
2. Click the magnifying glass icon from the search bar → choose "Change Search Settings".
3. Click "Add more search providers...".
4. Install two additional search providers from that list and restart the browser if asked.
5. Access https://bugzilla.mozilla.org from the Location Bar.
6. Click the magnifying glass icon from the search bar → choose "Add Bugzilla@Mozilla Search".
7. Click the menu button → go to "Search" → set the "Default Search Engine" to "Bugzilla@Mozilla".
8. Make the width of the browser window smaller and type in the Search Bar a random search term (e.g. example).

Expected result: The search pane's content is displayed properly in case of narrow browser windows.

Actual result: The search pane's content is cutoff by it's margin and there's no ellipsis used for longer strings.

Screenshot: http://i.imgur.com/23VNO8I.png
Possible duplicate of bug # 1104325
(Assignee)

Updated

3 years ago
Summary: Resizing the window after installing additional search providers results in a cutoff search pane → A long default search provider name can mess up the layout of the one-off buttons when the panel is small
(Assignee)

Comment 2

3 years ago
Created attachment 8528509 [details] [diff] [review]
Fix
Assignee: nobody → florian
Attachment #8528509 - Flags: review?(felipc)
Attachment #8528509 - Flags: approval-mozilla-release?
Attachment #8528509 - Flags: approval-mozilla-beta?
Attachment #8528509 - Flags: review?(felipc) → review+
(Assignee)

Comment 3

3 years ago
Screenshot without patch: http://i.imgur.com/oGhJeog.png and with the patch: http://i.imgur.com/9rUkMEQ.png
status-firefox35: --- → affected
status-firefox36: --- → affected
tracking-firefox34: --- → +
tracking-firefox35: --- → +
tracking-firefox36: --- → +
Flags: firefox-backlog?
Flags: qe-verify+
Comment on attachment 8528509 [details] [diff] [review]
Fix

Reviewed with Florian. Release+ Beta+
Attachment #8528509 - Flags: approval-mozilla-release?
Attachment #8528509 - Flags: approval-mozilla-release+
Attachment #8528509 - Flags: approval-mozilla-beta?
Attachment #8528509 - Flags: approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/c0c3429824fc
https://hg.mozilla.org/releases/mozilla-release/rev/c0c3429824fc
status-firefox34: affected → fixed
Blocks: 1101642
Verified fixed on Firefox 34.0 (build2 / 20141125180439) using Windows 7 64-bit, Mac OS X 10.9.5 and Ubuntu 12.04 LTS 32-bit.

Although most of the pane's elements now react properly in this scenario, the "Change Search Settings" button is still showing this issue:
 - the button's label is still being cutoff (on all platforms),
 - on Linux, the bottom border of the button is completely missing.
Here's a screenshot that shows both of these side-effects: http://i.imgur.com/IHmoQX8.png.

Perhaps this should be treated in a separate bug. Florian, what do you think?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox34: fixed → verified
Flags: needinfo?(florian)
Resolution: --- → FIXED
Hi Florian, can you provide a point value.
Iteration: --- → 37.1
Flags: needinfo?(florian)
Flags: firefox-backlog?
Flags: firefox-backlog+
(Assignee)

Comment 9

3 years ago
(In reply to Andrei Vaida, QA [:avaida] from comment #7)
> Verified fixed on Firefox 34.0 (build2 / 20141125180439) using Windows 7
> 64-bit, Mac OS X 10.9.5 and Ubuntu 12.04 LTS 32-bit.
> 
> Although most of the pane's elements now react properly in this scenario,
> the "Change Search Settings" button is still showing this issue:
>  - the button's label is still being cutoff (on all platforms),
>  - on Linux, the bottom border of the button is completely missing.
> Here's a screenshot that shows both of these side-effects:
> http://i.imgur.com/IHmoQX8.png.
> 
> Perhaps this should be treated in a separate bug. Florian, what do you think?

Yes, separate bug (if we think it needs fixing). I tested this yesterday and discussed it with Felipe. We agreed that the "Change Search Settings" button wasn't worth fixing for beta (I'm not even sure that cropping the text with an ellipsis would actually be better that the current cut-off text) because it doesn't mess up the layout of the rest of the panel like the header did.

Leaving this open because I expect to land the fix for Firefox 36 too.
Status: RESOLVED → REOPENED
Points: --- → 1
Flags: needinfo?(florian)
Resolution: FIXED → ---
(Assignee)

Comment 10

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/5c24bc95888c
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5c24bc95888c
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-firefox36: affected → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
(Assignee)

Comment 12

3 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3c2c29abfa35
status-firefox35: affected → fixed
Verified fixed on Nightly 37.0a1 (2014-12-07) and Aurora 36.0a2 (2014-12-08) as well, using Windows 7 64-bit, Ubuntu 12.04 LTS 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
status-firefox36: fixed → verified
status-firefox37: --- → verified
Verified fixed on Firefox 35.0b6 (20141222200458) using Ubuntu 12.04 LTS 32-bit, Windows 8.1 64-bit and Mac OS X 10.9.5.
status-firefox35: fixed → verified
You need to log in before you can comment on or make changes to this bug.