Active state for the selected devtools tab is wrong

RESOLVED FIXED in Firefox 36

Status

()

Firefox
Developer Tools
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bgrins, Assigned: bgrins)

Tracking

Trunk
Firefox 36
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
I'm assuming this a regression of bug 1102369.  When active, the selected tab is getting the normal active state as a background.
(Assignee)

Comment 1

4 years ago
Created attachment 8528470 [details] [diff] [review]
devtools-tab-active.patch

This is unfortunate, but we need this workaround for now to make sure that we are overriding the :hover:active state (which includes the .theme-light/.theme-dark prefix since they are using special, non-variable, colors).
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8528470 - Flags: review?(vporof)
Attachment #8528470 - Flags: review?(vporof) → review+
https://hg.mozilla.org/mozilla-central/rev/4f555b40f01e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
I don't see why you didn't use the :not() selector :
.devtools-tab:not([selected]):hover:active {
  // Active state code
}
You need to log in before you can comment on or make changes to this bug.