Closed Bug 1105104 Opened 5 years ago Closed 5 years ago

[Classic] Missing Treelines (yet again)

Categories

(Core :: XUL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: mnyromyr, Assigned: jwatt)

References

Details

(Keywords: regression)

Attachments

(4 files)

SM Linux trunk 2014-11-25.

The treelines are missing in the Classic theme again. *sigh*
Both browser (eg Bookmarks sidebar) and Mailnews (e.g. Folder Pane, Thread Pane) are affected.

According to dcsm.n-b, the regression window is this:

Last good: 2014-10-16 06:00:00 PDT
First bad: 2014-10-16 22:11:00 PDT
I am seeing this on Modern.
Bug 1083501 looks like a possible cause, hence I suppose treelines are broken in FF trunk as well (despite not being used officially, they should still work).
Flags: needinfo?(jwatt)
(In reply to Karsten Düsterloh from comment #0)
> Last good: 2014-10-16 06:00:00 PDT
> First bad: 2014-10-16 22:11:00 PDT

I don't know which builds you're using, and even if I did I'd prefer not to have to go dig up associated revision numbers. Can you provide a pushlog link with the actual revisions, please?
Flags: needinfo?(jwatt)
Actually, never mind. I do see a bug in https://hg.mozilla.org/mozilla-central/rev/8599bf367763
Assignee: nobody → jwatt
Blocks: 1083501
Component: UI Design → XUL
Keywords: regression
OS: Linux → All
Product: SeaMonkey → Core
Hardware: x86_64 → All
Attached patch patchSplinter Review
Attachment #8529697 - Flags: review?(bas)
WFM on SM-Trunk Linux x86_64.
Attached image treelines.png
Well, the treelines are back, but look at the appearance on a SM before the bug, left side, and a SM with the patch, right side.

Could be a refresh issue.
Attachment #8529697 - Flags: review?(bas) → review+
Comment on attachment 8529697 [details] [diff] [review]
patch

Yes, looks good here as well; and I don't see any unwanted fragments.
Attached image treel2.png
(In reply to Karsten Düsterloh from comment #9)
> Yes, looks good here as well; and I don't see any unwanted fragments.

Hm. I have created a fresh profile for my SM-Trunk Linux x86_64, using the patch,  minimally configured, and the fragments are still there.
Attached image TB-treelines.png
I'm seeing them too on TB on Win7. The interesting thing is, when I move with the mouse upwards the before hovered treechildren have no artifacts but by moving the mouse down again they reappear.
https://hg.mozilla.org/mozilla-central/rev/781ba31f9b11
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
(In reply to Hartmut Figge from comment #10)
> (In reply to Karsten Düsterloh from comment #9)
> > Yes, looks good here as well; and I don't see any unwanted fragments.
> 
> Hm. I have created a fresh profile for my SM-Trunk Linux x86_64, using the
> patch,  minimally configured, and the fragments are still there.

I have to correct myself: I do see these "fragments" (now?) as well.
It looks as if the test for "// Paint full vertical line only if we have next sibling." is not working correctly sometimes and drawing an unwanted vertical line then.
If this is still an issue, please provide the information detailed in comment 4.
Depends on: 1116952
Duplicate of this bug: 1137125
This bug does not affect SM 2.32, but affects SM 2.33 (see duped bug 1137125).

It was fixed on 2014-12-01 with a Target Milestone of mozilla37.
Is that Gecko 37?
Will SM 2.34 include the fix?
Fix Verified with EN-US SeaMonkey 2.38a1 build by Ruediger Lahl, Gecko/20100101, Build 20150531140409 (Default Theme) on German WIN7 64bit
The fix was merged on the trunk 6 months ago. I sure hope it's in SM 2.36 (based on Gecko 39) to be released in 3 weeks!
You need to log in before you can comment on or make changes to this bug.