When scroll event falls through from subframe to top-level frame, apz scrolling is noticably slower.

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: mitchell, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141125030206

Steps to reproduce:

1. Visit http://ripdog.github.io/scrolling-testcase/
2. Scroll the subframe to the bottom.
3. Keep the mouse on the subframe, and scroll down again.


Actual results:

The entire page scrolls down about half as fast as normal. It scrolls the same distance, but so much slower that it's very noticable.


Expected results:

The whole page should scroll at the same speed as the subframe scrolled down. This is what happens with apz off.
(Reporter)

Updated

3 years ago
Blocks: 1086162
With all the event handling, wheel, and animation fixes that have happened since this bug, it should be fixed now. I can't reproduce it anymore. Feel free to re-open if it still happens.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.