Key pad for entering SIM pin randomly disappears

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: MarcoZ, Assigned: evanxd)

Tracking

({access, regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [b2ga11y p=1][b2ga11y stabilitiy])

When entering the SIM PIN with the screen reader, the keyboard seemingly randomly disappears after a few seconds, or sometimes immediately after it came up. Not predictable.

1. Turn on screen reader.
2. Restart Flame with an inserted SIM card.
3. Unlock.
4. Try to enter SIM PIN.

Expected: Keyboard should keep on top and one should be able to enter all 4 digits.
Actual: Sometimes entering one digit works, sometimes the keyboard disappears right when exploring, sometimes one can enter one digit, but the disappearance happens while looking for the second digit, sometimes, it just disappears by just letting it sit there for a few seconds. One can double-tap the password field again and againto bring it back up, but it will again disappear soon.

This is a recent regression, this used to work early in the week of November 17th.
Adding qawanted for branch checks and then a regression window if needed.
Keywords: qawanted
Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: Keyboard is disappearing when trying to type characters into the SIM Pin entry screen after a reboot when you have Screen Reader enabled.

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141126035924
Gaia: 41b7be7c67167f367c3c4982ff08651d55455373
Gecko: 7bcc6573d204
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Keyboard remains on screen so the user can type the full SIM pin in when screen reader is enabled.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141126060024
Gaia: db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko: 4646c3113273
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141126053129
Gaia: 348e8be961a5219ebed35c52e1f6f009985108ef
Gecko: 3545791f9d0f
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: ychung
Not sure if this is the same issue as bug 1102135, let's test this again when the patch there lands.
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
Mozilla-inbound Regression Window:

Last Working 
Device: Flame 2.2
BuildID: 20141117225125
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: 5ee39194ac67
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Device: Flame 2.2
BuildID: 20141117233625 
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: 6dbd7d78e775
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: 6dbd7d78e775

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko: 5ee39194ac67

Gecko Pushlog:
hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5ee39194ac67&tochange=6dbd7d78e775

Possibly caused by bug 1092888
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Broken by bug 1092888 - Morris can you take a look at this please.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(mtseng)
bug 1092888 has been backouted. I'll track this issue once it get reland.
Flags: needinfo?(mtseng)

Comment 7

4 years ago
Triage: blocking. Hi Morris, can you help to check if this still happens? thanks.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(mtseng)
I cannot reproduce this issue in my local latest master build.
Flags: needinfo?(mtseng)
Assignee: nobody → evanxd
Status: NEW → ASSIGNED
(Assignee)

Comment 9

4 years ago
I could not reproduce this too.

The environment:
Build ID               20141225160202
Gaia Revision          6f2b5a28da17cb75a1802958a2c1dda225898bb8
Gaia Date              2014-12-25 15:54:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/986ef444a8bb
Gecko Version          37.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141204.004231
Firmware Date          Thu Dec  4 00:42:42 EST 2014
Bootloader             L1TC00011880
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [b2ga11y p=1] → [b2ga11y p=1][b2ga11y stabilitiy]
You need to log in before you can comment on or make changes to this bug.