[Usage] Some strings aren't automatically translated on language switch

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
--
minor
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: mai)

Tracking

({papercut})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

Some strings (eg. data usage limit values (MB/GB) in FTE) aren't automatically translated when user changes language while app is open. 

It's quite minor, but still nice to have and easily achievable with data-l10n-* attributes.
blocking-b2g: --- → 2.2?
I nominated this bug but, Oleg, can you provide confirmation that this is still happening?
Flags: needinfo?(azasypkin)
(In reply to Salvador de la Puente González [:salva] from comment #1)
> I nominated this bug but, Oleg, can you provide confirmation that this is
> still happening?

Yep, I still see it. You can check with the following STR:

* Open Cost Control app and go to the Data Alert FTE screen;
* Enable data alert and observe "When use is above"  input;
* Switch to Settings and change language to Arabic for example;
* Switch back to Cost Control app and observe input one more time;

The same is true for "Data usage limit" dialog itself. Though it's correctly re-translated if you tap on that input, that's why I considered it as a minor issue :)
Flags: needinfo?(azasypkin)
qawanted to see if it's still reproducible on master.
Keywords: qawanted
Shing, are you still on top of usage app?
Flags: needinfo?(slyu)
Flags: needinfo?(jlorenzo)
Can't reproduce on the following build:
Gaia-Rev        e6a5e65ec98f3dee36c55809639c4800e52fbc19
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/dcb4c5573aef
Build-ID        20150119160230
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880

When I switched to Arabic language, the "1GB" text is translated to Arabic immediately.
Flags: needinfo?(slyu)
Hmm, strange I see "GB 1" instead of "‎جيجا بايت ‎1" right after language switch.
I am able to reproduce on [1] if I follow the exact STR in comment 2. The main page is not affected.


[1]Gaia-Rev        e6a5e65ec98f3dee36c55809639c4800e52fbc19
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/dcb4c5573aef
Build-ID        20150119160230
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.jlorenzo.20141211.144125
FW-Date         Thu Dec 11 14:41:42 CET 2014
Bootloader      L1TC000118D0
Flags: needinfo?(jlorenzo)
Posted video Bug1105367
(In reply to Oleg Zasypkin [:azasypkin] from comment #6)
> Hmm, strange I see "GB 1" instead of "‎جيجا بايت ‎1" right after language
> switch.
I also see that behavior. Environmental variables:
Flame 3.0 device
BuildId: 20150120065306
Gecko: 11fb7e0
Gaia: 174cc78
Platform: 38.0a1
Confirming that I see comment 6 results in latest Flame 3.0 Nightly

Hmm, strange I see "GB 1" instead of "‎جيجا بايت ‎1" right after language switch.

Device: Flame 3.0 Master
BuildID: 20150120010227
Gaia: a5c5ac093814a80b0627514c3bd5f9e96c096a4b
Gecko: c1c6840d9255
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I can reproduce it now after reboot. Same build as in comment 5.
triage: blocking for it's non-translated string.
blocking-b2g: 2.2? → 2.2+
Assignee

Updated

5 years ago
Assignee: nobody → marina.rodrigueziglesias
Assignee

Comment 12

5 years ago
Posted file patch v1.0
Hi Salva,
would you mind reviewing the patch?
Regards
Attachment #8552353 - Flags: review?(salva)
Comment on attachment 8552353 [details] [review]
patch v1.0

Nice catch! Thank you!
Attachment #8552353 - Flags: review?(salva) → review+
Assignee

Comment 14

5 years ago
Master: dd90392f51884f86c55f8d8729fe65fd586c9189
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee

Comment 15

5 years ago
Comment on attachment 8552353 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature
[User impact] if declined: non-translated string
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low Risk
[String changes made]:
Attachment #8552353 - Flags: approval-gaia-v2.2?(release-mgmt)
Target Milestone: --- → 2.2 S4 (23jan)
Attachment #8552353 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0 and 2.2.

Following STR at comment 2, all strings are correctly translated.

Note: For 319MB Flame the previous app gets killed when switching between apps; I had to set the memory to 512MB in order to successfully do the STR.

Verified on:
Device: Flame 3.0
BuildID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.