Downloaded file does not unzip properly

CLOSED INVALID

Status

Core Graveyard
File Handling
--
major
CLOSED INVALID
17 years ago
2 years ago

People

(Reporter: Garrett Smith, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
1. Go to: http://java.sun.com/products/javabeans/glasgow/jaf.html#download
2. Click Download
3. Choose an ftp site (you may have to reload the page to remedy a page-caching
glitch)
4. After the file has downloaded Doulble click it's icon (note: another bug
garbles the filename to something unique, like fv25gs55h0)

Results I had:

Mixed. All but one time, I got to step 4 and had an empty folder.
The one time this didn't happen, I got NO folder. Stuffit Expander showed that
the files were being extracted in it's dialog status.
I have tried this twice with each of the following urls:

http://java.sun.com/products/javamail/index.html
http://java.sun.com/products/javabeans/glasgow/jaf.html#download

All four attempts failed.

I successfully downloaded the files in IE5.01b

Comment 1

17 years ago
Works for me with 2001-11-18-08 under Windows 2000, and no garbled filename.
The downloaded file opens fine in WinZip.
What build are you using (please always state this in your reports)?
Have you tried a recent nightly build from:
  http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Summary: Downloaded file does not unzip properly → Downloaded file does not unzip properly
(Reporter)

Comment 2

17 years ago
Moz 0.9.5; Build ID 2001101516
OS: Mac OS 10.04

There are errors related to downloading JAF that are not Mozilla's fault (not a
bug).

Additionally, I found an error with the folder that Stuffit Expander extracted
from the JAF zipfile. The folder containing JAF that was unzipped was hidden
(even in IE, even in Opera). This had to do with the folder name being
recognized by OS 10 as a type that should be hidden, and has nothing to do with
the browser. 

The problem downloading JavaMail I still consider a bug. 


Also, we don't have winzip for the mac. 

Comment 3

17 years ago
Please try with a newer build - downloading Javamail works fine in Windows and 
Linux for me with today's nightly build.  The downloaded file opens fine in 
WinZip and the command line unzip under Linux.
i see this using 2001.11.19.08-comm bits on mac os 10.1. whether i download the
file and then expanded it later with Stuffit Expander, or have the helper app
dialog open it up directly, Stuffit Expander goes thru the motions of
decompressing the files, but i cannot find those files. [eg, a Sherlock search
for files containing "JAF" in their name turned up nothing.]

methinks this issue is specific to mac os x, so over to pink for triage.
Assignee: law → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

17 years ago
Hi, under additional comment #2 by Garrett Smith (that's me):

"The folder containing JAF that was unzipped was hidden
(even in IE, even in Opera)"

The JAF unzipped folder is hidden because it is named ".1" and anything
beginning with a "." is hidden. The folder can be seen in OS9.

Regarding JavaMail, I don't know what to make of it. I hope I'm not wasting your
time!

Summary: 
  JAF ...........Sun's fault or Stuffit's fault (not sure)
  JavaMail ......Problem only in Mozilla on my build.
(Assignee)

Comment 6

17 years ago
I downloaded

http://java.sun.com/products/javamail/index.html

just fine. it unzipped correctly and the files are there. the other url is a bad
stuffit archive. not our problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
mass verification of Invalid bugs: to find all bugspam pertaining to this,
set your search string to "MagaritaLuisaChascarilloAvoidsInvalidBugs".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. where relevant, do check that it's actually still a problem with ***recent
trunk builds*** on the all appropriate platform[s]

b. provide clear, compelling reasons why this bug should be considered a valid one.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
I found the file using OS9. I resolved this problem long ago, and from what I
remember, it was a problem with the folder name beginning with .1 or something
like that. It was really odd and confusing me for a while. I don't have a clear
recollection of the exact details of the problem.

Anyway, the problem was not with Mozilla.

Garrett
Status: VERIFIED → CLOSED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.