Unable to handle a call when the device is locked

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 fixed)

Details

(Whiteboard: [fromAutomation])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8529758 [details]
2014-11-27-15-40-50.png

The user is unable to handle an incoming call when the device is unlocked. Both Answer and Reject call options are not available. 
This issue is reproducible manually, repro rate is 3/5.

#STR:
1. From the Homescreen, Lock the device by pressing the power button
2. From a second device call the Locked device
3. When the locked device receives the call, try to handle it by either answering or rejecting it. 

#Expected results:
Answer and reject options are available, the user can handle the incoming call by slide left or right

#Actual results: 
Answer and reject options are not available, the user cannot handle the incoming call

This issue is causing intermittent failure in test_dialer_receive_call_with_locked_screen.py(smoketest)

First time I saw this test failing on Jenkins: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.b2g-inbound.ui.functional.smoke/1400/HTML_Report/

Build info: Device firmware (date) 	26 Nov 2014 10:04:48
Device firmware (incremental) 	eng.cltbld.20141126.130435
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	26 Nov 2014 07:35:56
Gaia revision 	7878734c7baf
Gecko build 	20141126094226
Gecko revision 	6780420c1572
Gecko version 	36.0a1

I'll attach a screenshot, video and logcat of the issue.
(Reporter)

Comment 1

4 years ago
Created attachment 8529759 [details]
logcat
(Reporter)

Updated

4 years ago
Keywords: qablocker, qaurgent, regressionwindow-wanted, smoketest
Whiteboard: [fromAutomation]
Component: Gaia::Dialer → Gaia::System::Lockscreen
Whiteboard: [fromAutomation] → [fromAutomation][Systemsfe]
(Reporter)

Comment 2

4 years ago
Regression range, based on b2g-inbound:
Last working:
Device firmware (date) 	26 Nov 2014 05:28:03
Device firmware (incremental) 	eng.cltbld.20141126.082752
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	26 Nov 2014 04:17:38
Gaia revision 	caa6dd8e6c5a
Gecko build 	20141126044226
Gecko revision 	3098b45e9a24
Gecko version 	36.0a1

First failing:
Device firmware (date) 	26 Nov 2014 07:27:15
Device firmware (incremental) 	eng.cltbld.20141126.102700
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	26 Nov 2014 06:39:17
Gaia revision 	58f8e8dc6a58
Gecko build 	20141126070226
Gecko revision 	84573000fec1
Gecko version 	36.0a1

Gaia changes: https://github.com/mozilla-b2g/gaia/compare/caa6dd8e6c5a...58f8e8dc6a58

Gecko changes: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=%203098b45e9a24&tochange=84573000fec1

I think that patch https://github.com/mozilla-b2g/gaia/commit/a445aec48e9260d3e4b3f6980de73b90f7f99314 has caused this issue.

I reverted this patch locally, and I couldn't reproduce the issue anymore.
(Reporter)

Updated

4 years ago
Keywords: regressionwindow-wanted → regression
Fixed by the backout of bug 1078448.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: --- → fixed
Component: Gaia::System::Lockscreen → Gaia::Dialer
Keywords: qablocker, qaurgent, smoketest
Resolution: --- → FIXED
Whiteboard: [fromAutomation][Systemsfe] → [fromAutomation]
You need to log in before you can comment on or make changes to this bug.