SVG clipPaths not showing up when loaded in Image element using Blob data and createObjectURL

RESOLVED DUPLICATE of bug 841920

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 841920
4 years ago
4 years ago

People

(Reporter: Mihai, Unassigned)

Tracking

31 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8529814 [details]
index6.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Trying to create a SVG image dynamically from JS, using some clipPath definitions.
Create object url from SVG data then trying to load it in an Image object, and drawing the image in a canvas element. See attached html


Actual results:

Clip paths are not shown in the resulting Image


Expected results:

Clip paths are shown in the resulting Image
(Reporter)

Updated

4 years ago
Severity: normal → blocker
(Reporter)

Updated

4 years ago
Severity: blocker → critical

Updated

4 years ago
Severity: critical → normal

Updated

4 years ago
Component: General → SVG
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841920
You need to log in before you can comment on or make changes to this bug.