Closed Bug 1106076 Opened 8 years ago Closed 5 years ago

The music goes soft while using the keypad of the emergency dialer

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: jlorenzo, Unassigned)

References

Details

Pre-requisites: Have some earplugs plugged in. Have a passcode on the lockscreen

STR
1. Play some music
2. Lock the device
3. Try to unlock it to show the passcode keypad
4. Go to the emergency dialer
5. Press some keys on the keypad

Expected results
Like for the regular dialer keypad, you should hear the tone over the music.

Actual result
The music goes soft for about a second, you barely hear the tone and then the music is back to normal again.
I've just tried this on my Flame with a master build and I cannot reproduce it, neither with earplugs or without.
I checked again against a master build[1] and I can reproduce the issue. I used the Music app with mid-volume (repro'd with full and low volume too) and with or without earplugs. 

[1] Gaia-Rev        0e429d970c160e580e19e61ad8ff5612de159f00
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/035a951fc24a
Build-ID        20141207160206
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Thanks for having tested again, this is really bizarre. I'll have to double-check.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.