Call SIM indicator is misaligned in RTL

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: drs, Assigned: drs)

Tracking

unspecified
2.2 S4 (23jan)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [c=1])

Attachments

(5 attachments)

Assignee

Description

5 years ago
Posted image Screenshot
The Callscreen SIM indicator is misaligned with the duration in RTL mode. It should be on the right, but it's on the left, as it would be in LTR mode.
Assignee

Comment 1

5 years ago
PR: https://github.com/mozilla-b2g/gaia/pull/26562

I snuck in a fix for the alignment of the contact/phone number text. It's minor enough that I don't think it's worth filing another bug for.
Attachment #8530445 - Flags: review?(gtorodelvalle)
Assignee

Comment 2

5 years ago
Carol, I nudged down the SIM indicator by 0.5rem so that Arabic text in the duration field, such as the translation of "connecting", would fit without overlapping with the indicator.
Attachment #8530446 - Flags: ui-review?(chuang)
Any updates regarding this bug ?
Flags: needinfo?(drs.bugzilla)
Assignee

Comment 4

5 years ago
Comment on attachment 8530445 [details] [diff] [review]
Fix alignment of Callscreen SIM indicator in RTL mode.

I'll take this to completion since it's so small. Gabriele, please review this since Germán is on PTO.
Flags: needinfo?(drs.bugzilla)
Attachment #8530445 - Flags: review?(gtorodelvalle) → review?(gsvelto)
Assignee

Comment 5

5 years ago
Comment on attachment 8530446 [details]
Proposed visual design after fix

Toggling UI review for visibility.
Assignee

Updated

5 years ago
Attachment #8530446 - Flags: ui-review?(chuang)
Assignee

Comment 6

5 years ago
Comment on attachment 8530446 [details]
Proposed visual design after fix

Carol, please have a look at this as in comment 2.
Attachment #8530446 - Flags: ui-review?(chuang)
Comment on attachment 8530445 [details] [diff] [review]
Fix alignment of Callscreen SIM indicator in RTL mode.

Review of attachment 8530445 [details] [diff] [review]:
-----------------------------------------------------------------

Overall this looks good to me, just one question (see below).

::: apps/callscreen/style/oncall.css
@@ +959,5 @@
>  
> +  html[dir="rtl"] .big-duration .sim {
> +    left: auto;
> +    right: 0;
> +  }

Is this required to properly align the text to the above duration in RTL mode? This CSS has become really complicated, let's hope we'll be able to simplify it some day :-(
Attachment #8530445 - Flags: review?(gsvelto) → review+
Attachment #8530446 - Flags: ui-review?(chuang) → ui-review+
Can we land this?
Flags: needinfo?(drs.bugzilla)
Assignee

Comment 9

5 years ago
https://github.com/mozilla-b2g/gaia/commit/240448df5338fa29924b38ea693e2d09cf93c7fb
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(drs.bugzilla)
Resolution: --- → FIXED
Target Milestone: 2.2 S1 (5dec) → 2.2 S4 (23jan)
Assignee

Comment 10

5 years ago
Comment on attachment 8530445 [details] [diff] [review]
Fix alignment of Callscreen SIM indicator in RTL mode.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Sub-bug of Dialer RTL support, bug 1071918.
[User impact] if declined: See attachment 8530437 [details].
[Testing completed]: Gabriele and I tested this.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8530445 - Flags: approval-gaia-v2.2?
Attachment #8530445 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2

Comment 13

5 years ago
This issue verified successfully on Flame 2.2:
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/75a462a58d7a
Build-ID        20150121002607
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Refer to picture

Comment 14

5 years ago

Comment 15

4 years ago
This issue has been verified successfully on Flame 3.0.
Reproduce rate:0/5.
Attachment:Verify_RTL_SIM.png

Flame 3.0 build:

Gaia-Rev        740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/940118b1adcd
Build-ID        20150202010229
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.044915
FW-Date         Mon Feb  2 04:49:25 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]

Comment 16

4 years ago
Posted image Verify_RTL_SIM.png
You need to log in before you can comment on or make changes to this bug.