Closed Bug 1106255 Opened 5 years ago Closed 5 years ago

Regression: Wrong viewport in content (Android)

Categories

(Firefox for Android :: Toolbar, defect, major)

36 Branch
ARM
Android
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 37
Tracking Status
firefox36 --- fixed
firefox37 --- fixed
fennec 36+ ---

People

(Reporter: vlposta, Assigned: kats)

References

Details

(Keywords: regression, reproducible, testcase)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Android; Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Build ID: 20141129030207

Steps to reproduce:

I see any web pages (this too) and set font in setting to large


Actual results:

Font is too small and i cannot read this pages - in older version 29141123 this problem not exist and font size on all web pages is OK


Expected results:

Font sizes same as in older version 20141123
Please provide an example page that you are using for testing.
Flags: needinfo?(vlposta)
Attached image Version_20141123.png
Flags: needinfo?(vlposta)
Attached image Version_20141129.png
Many pages have this isue and if i reply for example in disscusion (see attachmets please), i mus always manualy zoom ...
Assuming some content regression we should track this (as per filed against trunk and indication that this used to work). Is this happening on other sites? Do you have specific URLs?
tracking-fennec: --- → ?
On many sites, e.g. :

http://www.novinky.cz/

http://www.novinky.cz/diskuse?id=385223&articleId=/domaci/354928-vanoce-neprekvapi-teploty-kolem-nuly-snehu-malo.html&sectionId=8

http://www.parlamentnilisty.cz/

and other - in older build 20141123 this isue not exist and i mus now use this older build... :-(
Thanks. I was able to reproduce on a sample test-page of mine. I'll look for a regression-window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: in-testsuite?
Summary: Font size on many pages is now too small → Regression: All default in content text-size is small
Last good revision: b379f1bc58e1
First bad revision: 285c55e9b40d
Pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?
fromchange=b379f1bc58e1&tochange=285c55e9b40d

c3ad8948bea9	David Anderson — Put meta viewport support behind a pref (bug 1092450, r=kats).

Reproducible on simple content my media test page @ http://people.mozilla.org/~atrain/mobile/tests/media.html
Blocks: 1092450
Flags: needinfo?(bugmail.mozilla)
Summary: Regression: All default in content text-size is small → Regression: Wrong viewport in content (Android)
Hardware: Other → ARM
Version: Firefox 37 → Firefox 36
Severity: normal → major
Component: General → Graphics, Panning and Zooming
Doh, my mistake. By turning off the pref on fennec we disabled font inflation, even though the viewport code in browser.js is still getting run just fine. I should have realized that would happen since i had to enable the pref for the font inflation tests. We just need to turn the pref back on in fennec.
Assignee: nobody → bugmail.mozilla
Flags: needinfo?(bugmail.mozilla)
Comment on attachment 8530849 [details] [diff] [review]
Patch

Review of attachment 8530849 [details] [diff] [review]:
-----------------------------------------------------------------

r=me assuming that should be "true"
Attachment #8530849 - Flags: review?(dvander) → review+
https://hg.mozilla.org/mozilla-central/rev/789bf02e6662
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
This is needed on mozilla-aurora (36).
Comment on attachment 8530849 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1092450
[User impact if declined]: font inflation is completely disabled in fennec.
[Describe test coverage new/current, TBPL]: on m-c, tested via automated tests
[Risks and why]: low risk, just a pref change for fennec
[String/UUID change made/needed]: none
Attachment #8530849 - Flags: approval-mozilla-aurora?
Attachment #8530849 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
oh, this is fun, we have a regression in tsvgx:
http://graphs.mozilla.org/graph.html#tests=%5B%5B281,63,29%5D%5D&sel=none&displayrange=30&datatype=running

but since this looks related to the change 1.5 weeks prior which resulted in a regression:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=c3ad8948bea9

I am going to call this a wash since our overall performance is not affected.
tracking-fennec: ? → 36+
You need to log in before you can comment on or make changes to this bug.