[Downloads] Music file does not open/play from the download list

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: psiphantong, Assigned: squib)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-1] [2.2-flame-reduced-run], )

Attachments

(3 attachments)

Reporter

Description

5 years ago
Posted file mp.txt
Description:
When downloading mp3s and going to the the download list, the music does not open/play
  
Repro Steps:
1) Update a Flame device to BuildID: 20141201040205
2) Go the browser, download a mp3 file from https://owd.tid.es/dm/
3) Tap the notification
4) Tap play

  
Actual:
music does not open/play

Expected: 
music open/play
  
Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (Unknown)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Note: downloaded mp3 does play on the music app and the previewing ringtone from download list

  
Repro frequency: 3/3, 100%
See attached: video, logcat, https://www.youtube.com/watch?v=FZeoQwUMNYQ
Reporter

Comment 1

5 years ago
This issue does not reproduce on the Flame 2.1, music file open/plays.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Basic user flow is broken. Users should be able to open recently downloaded mp3 files. Also this is a regression. Nominating to block for 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20141119044505
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: aa72ddfe9f93
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141119181906
Gaia: 8e09627d75acd4abced0ab81983b5b5de6d15881
Gecko: 49fd5b055148
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: 49fd5b055148
Broken Gaia / Working Gecko = Repro
Gaia: 8e09627d75acd4abced0ab81983b5b5de6d15881
Gecko: aa72ddfe9f93
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e64428c5b2dce5db90b75a5055077a04f4bd4819...8e09627d75acd4abced0ab81983b5b5de6d15881

B2G Inbound
Last working
BuildID: 20141119102305
Gaia: 2cdd5ef8e1b54dc9063a88c8e0b2be81eb23a08d
Gecko: 3b47fb935a09
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141119105305
Gaia: ace8153b0db6fa89f006f22f76ce338a258203c7
Gecko: 037abc84a42c
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 2cdd5ef8e1b54dc9063a88c8e0b2be81eb23a08d
Gecko: 037abc84a42c
Broken Gaia / Working Gecko = Repro
Gaia: ace8153b0db6fa89f006f22f76ce338a258203c7
Gecko: 3b47fb935a09
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/2cdd5ef8e1b54dc9063a88c8e0b2be81eb23a08d...ace8153b0db6fa89f006f22f76ce338a258203c7
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Jim - this pushlog is only you're work, can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(squibblyflabbetydoo)
QA Contact: ckreinbring
Assignee

Comment 5

5 years ago
Posted file Fix it
Needs tests, but this fixes it.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Flags: needinfo?(squibblyflabbetydoo)
Reporter

Comment 6

5 years ago
This issue also occurs when the user is sharing music via bluetooth or sms
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Whiteboard: [2.2-exploratory-1] → [2.2-exploratory-1] [2.2-flame-reduced-run]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
blocking-b2g: 2.2? → 2.2+
Assignee

Updated

5 years ago
Duplicate of this bug: 1111092

Updated

5 years ago
Component: Gaia::System::Window Mgmt → Gaia::Music

Updated

5 years ago
See Also: → 1113000

Updated

5 years ago
Duplicate of this bug: 1113000
Duplicate of this bug: 1115314
Comment on attachment 8531777 [details] [review]
Fix it

Jim, looks like this issue has caused several bugs so let's land this patch on master first without tests, then add them later, or I believe there will be more bugs filed because it's a basic functionality broken.
Attachment #8531777 - Flags: review+
master: https://github.com/mozilla-b2g/gaia/commit/865e8430ecc1543472fd27d165a95fce76d6a651
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Blocks: 1117678
Tests followup will be in bug 1117678.
This bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/5

STR:
1.Go the Browser, download a mp3 file from url "http://owd.tid.es/dm/".
2.Tap the notification.
**The ".mp3" music is played automatically.

Flame 2.2 (Pass):
Build ID               20150316162504
Gaia Revision          d0e09d5e6367e558824f9cbf691da99cedf63037
Gaia Date              2015-03-16 17:14:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/793d61bb0bd4
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150316.195035
Firmware Date          Mon Mar 16 19:50:48 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.