Closed Bug 1106650 Opened 8 years ago Closed 8 years ago

[mobile] - Animated gif not displayed correctly

Categories

(Core :: Graphics: ImageLib, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1106423
Tracking Status
firefox35 --- unaffected
firefox36 --- affected
firefox37 --- affected

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(4 keywords)

See http://tweakimg.net/g/s/bonk.gif
At some point, in current trunk build on Nexus 5, on some point, the animated gif doesn't display correctly, the smiley sort of disappears.


This is not a problem in Firefox beta.

I think I've seen this bug for a week or so.
 9:07.80 LOG: MainThread Bisector INFO Oh noes, no (more) inbound revisions :(
 9:07.81 LOG: MainThread Bisector INFO Last good revision: 4a6bc0813732
 9:07.81 LOG: MainThread Bisector INFO First bad revision: 8987ca07b80e
 9:07.81 LOG: MainThread Bisector INFO Pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4a6bc0813732&tochange=8987ca07b80e

mfowler@mozilla.com
Wed Nov 26 21:22:25 2014 +0000	7ee7e774e19f	Seth Fowler — Bug 923302 - Add explicit memory reporting for SurfaceCache. r=njn,dholbert
1cbca597b025	Seth Fowler — Bug 1060869 (Part 4) - Update SurfaceCache prefs to increase the cache size. r=dholbert,tn
6bacacfaf339	Seth Fowler — Bug 1060869 (Part 3) - Make the SurfaceCache free only a fraction of its data on memory pressure. r=dholbert
5078e4014e21	Seth Fowler — Bug 1060869 (Part 2) - Store the first frame of a RasterImage in the SurfaceCache. r=tn
b0f351e99e1a	Seth Fowler — Bug 1060869 (Part 1) - Add lifetime control to SurfaceCache. r=dholbert
25bf6420a6ad	Seth Fowler — Bug 1057904 (Part 2) - Make imgFrame::LockImageData and UnlockImageData private. r=tn
63c554369c55	Seth Fowler — Bug 1057904 (Part 1) - Use RawAccessRef in FrameBlender and related classes and clean up. r=tn
Assignee: nobody → seth
Blocks: 1060869
Status: NEW → ASSIGNED
tracking-fennec: --- → ?
Component: Graphics → ImageLib
Keywords: reproducible
OS: Mac OS X → Android
Hardware: x86 → ARM
Probably a dupe of bug #1106423 -- the patch there also fixes this.
[Tracking Requested - why for this release]: fx36 regression
Assignee: seth → nobody
No longer blocks: 1060869
Status: ASSIGNED → RESOLVED
tracking-fennec: ? → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.