[Browser] Opening a new window causes transition issues

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: fmuyumba, Assigned: kgrandon)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-1][systemsfe], )

Attachments

(2 attachments)

Reporter

Description

5 years ago
Description:
Browser transition issues occur when a User tries to open a new window
   
Repro Steps:
1) Update a Flame device to BuildID: 20141201040205
2) Launch "Browser" app
3) Go to any website like CNN
4) Tap on ellipsis
5) Tap on "New window"
6) Observe what happens to the screen
  
Actual:
transition issues occur
  
Expected: 
No transition issues
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 100%
See attached: video clip, logcat: http://youtu.be/8kjBTgZl85o
Flags: needinfo?(dharris)
Reporter

Comment 1

5 years ago
This issue does NOT repro on Flame 2.1 (319mb)(Kitkat Base)(Full Flash)

Result:
There are NO browser transition issues

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---------------------------------------------------------------------------------------------------------

NOTE: 
Did NOT test the Flame 2.0 (319mb)(Kitkat Base)(Full Flash) because the feature does NOT exist
QA Whiteboard: [QAnalyst-Triage?]
This issue is also occurring when switching between any app and not just when opening a new window in browser. For example if the user is in messages and presses the call button the transition issues will be present when switching to the dialer app.
[Blocking Requested - why for this release]:

This issue is very apparent and is a high use case. Also a regression. Nominating this to block on 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
QA Contact: jmitchell
B2G-Inbound Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20141003101351
Gaia: 6394efe72ce08843ef183d42d7eb1f8263be47ed
Gecko: 9fef147b2da0
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20141003120246
Gaia: af5703b967e45816b30546faf0753a655878070e
Gecko: a5ed17226ef8
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 6394efe72ce08843ef183d42d7eb1f8263be47ed
Gecko: a5ed17226ef8
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: af5703b967e45816b30546faf0753a655878070e
Gecko: 9fef147b2da0

GAIA pushlog: https://github.com/mozilla-b2g/gaia/compare/6394efe72ce08843ef183d42d7eb1f8263be47ed...af5703b967e45816b30546faf0753a655878070e
-----------------------------------------------------------------------------------------------------

Caused by Bug 1071882 - Can you take a look Kevin?
Blocks: 1071882
Flags: needinfo?(kgrandon)
QA Contact: jmitchell
Assignee

Comment 5

5 years ago
Bug 1071882 is also in 2.1. If 2.1 is unaffected, then it's unlikely that this cased it. I will do some investigation though.
Flags: needinfo?(kgrandon)
Assignee

Comment 7

5 years ago
It seems that going back in time to right after bug 1106640 landed this issue does not reproduce, so I think that is not the cause of this bug. Doing another bisection here:

git bisect start
git bisect good 681e39f4d09c5e27d82e8c812f03dd4730d2b373

git bisect bad 84bdca8eb5b580bdf4b5c8dcb6bb43377a7b8994
Bisecting: 1253 revisions left to test after this (roughly 10 steps)
[311d7dee72b0dcadc1e0911985bf774edfbfeea4] Merge pull request #25592 from KevinGrandon/bug_1090562_missing_rocketbar_transitions

git bisect good
Bisecting: 626 revisions left to test after this (roughly 9 steps)
[16b17e7af2d711329de4581a5fca6614aa6c717b] Merge pull request #24259 from azasypkin/bug-1014686-template-refactoring

git bisect good
Bisecting: 312 revisions left to test after this (roughly 8 steps)
[7387e3f418b957ff27067c05f69afeaa6dab35ae] Merge pull request #26295 from bebef1987/test_ring

git bisect good
Bisecting: 156 revisions left to test after this (roughly 7 steps)
[609f3985df16ac2505a48a699ae9406b978ac03c] Merge pull request #26491 from davehunt/bug1074117-homescreen

git bisect bad
Bisecting: 77 revisions left to test after this (roughly 6 steps)
[ed25b3b0e66a0e13b4d0d45f54911dd5475bf660] Merge pull request #26399 from rexboy7/1060250-DLNA-player

git bisect bad
Bisecting: 38 revisions left to test after this (roughly 5 steps)
[c56c1012c87fc0b69ba8858afd132408c5948649] Merge pull request #26418 from wilsonpage/1104110

git bisect good
Bisecting: 19 revisions left to test after this (roughly 4 steps)
m[902a53dcd161414dcdff5cc61d9464827c5a7b9f] Merge pull request #26096 from KevinGrandon/bug_1098149_upgrade_jshint

git bisect good
Bisecting: 9 revisions left to test after this (roughly 3 steps)
[a9a75af0581b6a9549e795ce775ae267bb5a190c] Merge pull request #26401 from dwi2/bug1094094

git bisect bad
Bisecting: 4 revisions left to test after this (roughly 2 steps)
[9b6e75137adb65f702ce1612506461a71fa891ec] Bug 1096133 - Get rid of stopImmediatePropagation of hierarchy events

git bisect bad
Bisecting: 2 revisions left to test after this (roughly 1 step)
[ad6da527cf923722c2dba3378c0f6b2438c6579c] Merge pull request #26127 from russnicoletti/bug-1095832

git bisect good
Bisecting: 0 revisions left to test after this (roughly 1 step)
[99d24c8f931f9d665652fbdd8b66926d8fcffb10] Merge pull request #26395 from crh0716/1102156

git bisect good
9b6e75137adb65f702ce1612506461a71fa891ec is the first bad commit


Caused by bug 1096133
Blocks: 1096133
No longer blocks: 1071882
Thanks for the Bisection Kevin! 

Caused by bug 1096133 - can you take a look Alive?
Flags: needinfo?(alive)
Assignee

Updated

5 years ago
Attachment #8532228 - Flags: review?(alive)
Comment on attachment 8532228 [details] [review]
[PullReq] KevinGrandon:bug_1106666_window_transition_fix to mozilla-b2g:master

\O/
Flags: needinfo?(alive)
Attachment #8532228 - Flags: review?(alive) → review+
Assignee

Updated

5 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Assignee

Updated

5 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
Assignee

Comment 13

5 years ago
Oops, this was in the wrong component.
Component: Gaia::Browser → Gaia::System
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Yeojin, can you please verify that this issue has been fixed?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage-]
Flags: needinfo?(ychung)
This issue is verified fixed on Flame 2.2.

Result: The wallpaper does not appear during transitioning between apps, following STRs on Comment 0 and Comment 2, and in bug 1106640. No visual error occurs. 

Device: Flame 2.2 (319mb, KK, Full Flash)
Build ID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → 2.2+
Whiteboard: [2.2-exploratory-1] → [2.2-exploratory-1][systemsfe]
You need to log in before you can comment on or make changes to this bug.