Closed Bug 1106673 Opened 5 years ago Closed 4 years ago

crash in hang | IsWindow (right clicked on silverlight in WOWOW members ondemand)

Categories

(Core :: Plug-ins, defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: masayuki, Unassigned)

References

()

Details

(Keywords: crash, hang, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-0d4df950-a0cc-4782-883c-9366e2141202.
=============================================================

STR (you need to live in Japan and you need to subscribe WOWOW (a TV station of Japan)):

0. You need to create an account of WOWOW ondemand service.
1. Open http://mod.wowow.co.jp/detail?pg=005146&ep=002&fr=
2. Play the movie.
3. Right-click on the player.

Then, hanging up.
Is this a recent regresssion?
(In reply to Georg Fritzsche [:gfritzsche] from comment #1)
> Is this a recent regresssion?

Yeah, looks like a regression. I cannot reproduce this on Beta, but not so on Aurora. I'll test this with mozregression tomorrow.
Crash Signature: [@ hang | IsWindow] → [@ hang | IsWindow] [@ hang | ntdll.dll@0x3ceec ]
Oops, my beta was too old, but it was a good hint.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58c5a3427997&tochange=2893f60d5903
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cf89b5d018f8&tochange=2893f60d5903

Unfortunately, when I type "good" or "bad" after this test, the Nightly process hangs up. Therefore, mozregression doesn't work perfectly, so, I'm not sure I can find the regression cause.
Due to bug 1110018, I cannot build inbound builds locally... Sigh...
Depends on: 1110018
FYI, This also affects Flash Player.
I recently random experience this crashes when playing Flash Player video and minimize the Firefox window, I will cannot restore the window, and the Flash hang popup.

On Windows 8.1, Fx39b, whichever the dom.ipc.plugins.flash.disable-protected-mode be false or true.
Does this still reproduce for you?
Flags: needinfo?(masayuki)
Oh, I can reproduce this bug with neither Firefox 41.0.1 nor Nightly (44).
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(masayuki)
Resolution: --- → WORKSFORME
(In reply to YF (Yang) from comment #7)
> I recently random experience this crashes when playing Flash Player video
> and minimize the Firefox window, I will cannot restore the window, and the
> Flash hang popup.
> 
> On Windows 8.1, Fx39b, whichever the
> dom.ipc.plugins.flash.disable-protected-mode be false or true.

I think that it's different bug because I've experienced this bug only on the specific website. (i.e., I couldn't reproduce this bug with other websites.) So, this must be caused by that website accessing plugin with JS or something.
You need to log in before you can comment on or make changes to this bug.