Closed Bug 1106708 Opened 8 years ago Closed 5 years ago

[e10s] "Evernote Web Clipper" add-on does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

37 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
e10s + ---

People

(Reporter: kedar.bhise, Unassigned)

References

()

Details

(Keywords: addon-compat)

What is expected:
1. Clicking on Web Clipper icon in toolbar brings up the Web Clipper.
2. Previous login details are honored, and displayed.
3. Notebooks for that login are loaded, and notebook from last selection is selected by default.
4. In the tags field, typing the first few letters of tag names brings up matching tag names.
5. Clicking on "Clip URL", "Clip Article" or "Clip full page" button completes the clipping action.

What actually happens:
1. Success
2. Success
3. Success
4. Fail. Matching tag names are not displayed.
5. Fail. Clicking on the button produces no result whatsoever. The clipper form stays as is on the screen.
Blocks: e10s-addons
Keywords: addon-compat
Summary: "Evernote Web Clipper" add-on does not work with e10s → [e10s] "Evernote Web Clipper" add-on does not work with e10s
Thanks for testing, Kedar.

Alex or Gabriel: do either of you work on Evernote's Web Clipper extension for Firefox?
Hi Chris,
I'm working (PM) on the Evernote Web Clipper. We have a complete rewritten version of the Web Clipper pending approval by Mozilla. We won't update the old one anymore so we'll test the new one against this report and see if we can reproduce the problem.

New version available here:
https://addons.mozilla.org/en-US/firefox/addon/evernote-web-clipper/versions/
In reply to comment 2 :
I tried the new version 6.0 on 64bit Nightly 37.0a1, but the toolbar button stays mysteriously hidden. I know this is not the forum, but just thought it pertinent to let you know. If jbignert can let me know the right forum, I would be happy to pursue this problem there.

In reply to comment 1 :
My pleasure, Chris.

My Nightly 64bit updated today to 37.0a1 (2014-12-16). After the problems with Evernote Web Clipper ver 6.0 mentioned above, I uninstalled the extension and restarted. Went back to ver 5.9.1, and restarted again, in e10s.

Went through all the steps mentioned in the original bug report.

Things worked correctly this time with the "Clipped Successfully" screen showing up.
Verified the clip was added correctly to my Evernote account by logging into Evernote from a different device and checking for the clip.

Please let me know if there is any additional testing I could do to help you guys reach a confirmation. Else, I am happy for this bug to be closed.

And yes, a big thanks for the quick turnarounds.
After using the setup for one more day, I have to say that the behaviour is not predictable. I have had mixed success since my earlier update yesterday.
I would suggest keeping this bug open until the behaviour stabilises.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The 6.1 test version of the addon shows the menu and I can log in, but clips don't save successfully and I'm constantly warned that Evernote Web Clipper is making Nightly run slowly. I've tried changing the option from Send to Web to Send to Desktop but neither successfully clips.

Running Firefox 42.0a1 (2015-07-28) on my Mac
This issue affects me as well. When I click the Evernote Web Clipper icon in the toolbar, the icon turns from gray to blue, but the Web Clipper dialog does not open up and there is no way to actually clip the web page.

Running Firefox 48.0a1 (2016-03-10) on my Mac.
firefox 47 b1 with e10s enabled,the evernote web clipper not work.
 click the button on toolbar,has no dialog popup .
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
OS 	     Windows_NT 10.0 x86-64
Is there work in progress to make the web clipper addon multiprocess compatible?
Flags: needinfo?(jbignert)
Flags: needinfo?(jbignert)
With Firefox 57 only WebExtensions are permitted and are, by default, e10s compatible.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.