Youtube videos flickr while playing

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: TeoVermesan, Unassigned)

Tracking

36 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox34 affected, firefox35 affected, firefox36 unaffected, firefox37 unaffected, fennec-)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Tested with:
Device: Alcatel One Touch (Android 4.1.2)

Steps to reproduce:
1. Go to youtube.com 
2. Go to Menu -> "Request Desktop Site"
3. Choose a video
4. Choose "Activate" from the plugin doorhanger

Expected results:
- The video starts playing correctly

Actual results:
- on 34 Release and 35 Beta 1: After step 4 the screen is black. Tapping the play button will display an error message " An error occurred, please try again later". Choosing other videos, will flickr while playing: http://i.imgur.com/YD6ZGPV.png

- on 36 Aurora and 37 Nightly: the video plays with no issues

Comment 1

3 years ago
Works fine in Android 4.2.2

Updated

3 years ago
Flags: needinfo?(teodora.vermesan)
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

3 years ago
Long tapping on a youtube video on Firefox 34 or 35 Beta 1, nothing happens. (it's a flash video)
Long tapping on a youtube video on 36 Aurora and 37 Nightly, a context menu appears. (it's a html5 video)

Also http://www.intel.com/museumofme/mobile/index.htm flickr on all channels and no context menu appears on long tapping.
Flags: needinfo?(teodora.vermesan)
Can you find a regression-range so we can get evaluate a fix for Firefox 35?
Flags: needinfo?(teodora.vermesan)

Updated

3 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 4

3 years ago
Created attachment 8533117 [details]
youtube-logs.txt

I have attached the logs while playing the youtube desktop site video.
Alcatel One Touch (Android 4.1.2) is the only device I can reproduce the issue on.
I cannot find a regression range because at first try I've installed some older builds (for example 01/08, 15/09, 11/10) and I could not reproduce the issue. At a second try, I reproduce the issue on these buils. This happened a few times.
Flags: needinfo?(teodora.vermesan)
Fixed by MediaCodec work, but we are not uplifting of all that fix to Fx35. Fix will ride the trains.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
tracking-fennec: ? → -

Updated

3 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.