self-referencing iframe loop problem

RESOLVED DUPLICATE of bug 8065

Status

Core Graveyard
GFX
RESOLVED DUPLICATE of bug 8065
17 years ago
10 years ago

People

(Reporter: Peter Asemann, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I've created a document like this:

<html><iframe src="this.html"></html>

This document was saved as "this.html". As you see it references itself.
The IE will now recognize the document references itself and won't display it 
in the iframe. Mozilla isn't that smart and will go on forever, displaying the 
iframe in the iframe in the iframe...

I looked through the bug pages but could not find this bug. Maybe it's 
really "new".

Peter Asemann
> go on forever

Actually, it will not.  See bug 8065.

As that bug describes, there are legitimate reasons for having HTML such as what
you describe (eg dynamic sites).

Bug 8065 implemented a limit to the total frame nesting depth to prevent us
crashing, but there is no reason not to attempt to render this code.

*** This bug has been marked as a duplicate of 8065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.