Closed Bug 1106912 Opened 5 years ago Closed 5 years ago

Local domain access problem

Categories

(Firefox :: Address Bar, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1083634

People

(Reporter: zefling, Unassigned)

Details

(Whiteboard: [mozfr-community])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127110442

Steps to reproduce:

I want to go to a local domain and I put « local » in address bar.


Actual results:

I go to Google : https://www.google.fr/search?client=ubuntu&channel=fs&q=local&ie=utf-8&oe=utf-8&gfe_rd=cr&ei=Dk5-VNTDKaux8wfA5IGwCw


Expected results:

I want to go to : http://local/   a local domain in my hosts file.

/etc/hosts:
127.0.0.1       local
Maybe, You need whitelist.
Set  browser.fixup.domainwhitelist.xxxx = true in about:config, where xxxx = hostname.
I.e, in this case, browser.fixup.domainwhitelist.local = true.
No easiest way?  Okay for one machine, but for more ...
Component: Untriaged → Location Bar
(In reply to Zéfling from comment #2)
> No easiest way?  Okay for one machine, but for more ...

When you go to your search engine, there's a notification bar at the top that you can click to fix this immediately. That seems pretty easy to me.

We'll shortly land bug 1088050 on 35, which means using beta (after that lands) you can toggle a pref in about:config to turn this behaviour off completely.

Finally, we're working on making "local/" go directly to the page, instead of searching. That's bug 1083634, so I'm duping this there.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083634
Whiteboard: [mozfr-community]
You need to log in before you can comment on or make changes to this bug.