Bad wording and placement of sort options in new query.cgi

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
User Interface
P2
minor
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: gerv)

Tracking

2.15
Bugzilla 2.16

Details

(Whiteboard: [blocker will fix])

(Reporter)

Description

16 years ago
To reproduce:
1.  Go to the bottom of <http://landfill.tequilarista.org/bbaetz/query.cgi>.
2.  Look at the row containing the sort options and search button.

What you should see:
*   |                      Sort results by: [ bug number  :^] ( Search ) |

What you actually see:
*   | Sort results by: [ Bug Number   :^] ( Submit query )               |

What needs fixing:
1.  The row should be aligned on the right side of the page, not the left, to
    be easier to find and closer to the browser's vertical scrollbar (unless
    you happen to be using NeXT, in which case I apologize for not putting your
    needs ahead of everyone else's).
2.  `Submit query' should be translated into English, i.e. `Search'. :-)

Comment 1

16 years ago
I agree with 1, but I like submit query over search since this is the query 
page and you are querying the bugzilla db. To me, search indicates that 
you are too silly to know where the information is on your own so you have 
to search around for it, much like searching through your house/
appartment to find something you need. Submit query seems like a nicer 
way of putting it. I think that most users will understand submit query 
since it is the only thing that makes logical sense to press to get bug 
results.
This bug should be a comment on bug 16775, the bug about redesigning query.cgi.
 Bugs should not be filed on code that is not in the Bugzilla CVS repository.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
My mistake, the code in question is indeed in CVS.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 4

16 years ago
> this is the query page

No, it's the search page. That's why it has `Search for bugs' at the top.
`Submit query' is HTTP-/SQL-weenie-speak, and it should never have leaked into
Bugzilla's front end in the first place. Besides which, the first of the two
search buttons already says `Search'.

> search indicates that you are too silly to know where the information is on
> your own

I hope Zach doesn't use Google. Or AltaVista. Or Netscape Search. Or Yahoo.
(Assignee)

Comment 5

16 years ago
I have a fix for this; patch will appear in bug 110711.

Gerv
(Reporter)

Updated

16 years ago
Depends on: 110711
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16
"Search" makes sense given that we use it everywhere else on the page (including
the submit button at the top of the form with the exact same functionality as
the one at the bottom).

Right-aligning the sort list and search button, on the other hand, is
inconsistent with the alignment of all the other elements in the form.  It also
separates the sort list and search button from the activity radio buttons with
which they would otherwise logically be grouped and implies a strong connection
between the sort list and search button that does not actually exist.  Not only
should those elements not be right-aligned, it would make more sense if the
"Search" button were on its own line under the sort list.
Whiteboard: [blocker will fix]
(Assignee)

Comment 7

16 years ago
Fixed in bug 110711.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.