Closed Bug 110731 Opened 18 years ago Closed 9 years ago

Implement context menu for "shortcut icon" (favicon) to allow working with icon image file (view, copy, save etc. on right-clicking)

Categories

(SeaMonkey :: Location Bar, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: netdragon, Unassigned)

References

(Blocks 1 open bug)

Details

When a site has a shortcut icon, a right click on that icon should give you the
normal context menu along with a submenu that allows you to save the icon, view
it in the browser, copy it to clipboard, etc... just like normal images. This
should also be true for any other site icons like the ones in Search results of
the search sidebar.

If putting it in the right-click context menu wouldn't be good then maybe
another combination of clicks and keys would be good.
-> URL BAR

Assignee: asa → hewitt
Status: UNCONFIRMED → NEW
Component: Browser-General → URL Bar
Ever confirmed: true
QA Contact: doronr → claudius
Status: NEW → ASSIGNED
Priority: -- → P5
Target Milestone: --- → Future
Blocks: 120352
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
Priority: P5 → --
QA Contact: claudius → location-bar
Target Milestone: Future → ---
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Changed summary for greater ease of search.

Related Thunderbird Bug 424044 (Right-click should provide contextual actions for location bar icons) also wants a contextual menu for the favicon in location bar.
Ever confirmed: false
Summary: Right click on shortcut icon context menu allow to work with icon file → Implement context menu for "shortcut icon" (favicon) to allow working with icon image file (view, copy, save etc. on right-clicking)
wfm
WONTFIX. Extreme edge case with no general utility.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.