Closed Bug 1107494 Opened 8 years ago Closed 7 years ago

[e10s] No "Change Search Settings" button on about:home page

Categories

(Firefox :: Search, defect, P3)

37 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s m8+ ---

People

(Reporter: phorea, Assigned: ursula)

References

Details

(Whiteboard: [ui][fxsearch])

Reproduced with Nightly 37.0a1 2014-12-03 under Win 7 64-bit and Mac OSX 10.9.5.

STR: On about:home page click the magnifying glass

ER: "Change Search Settings" button is shown

AR: Nothing happens; there is no error in browser console.

The issue doesn't reproduce in about:newtab page.
It works fine in a non e10s window.
Dave, can you make this block the right bugs? Bug 1088660 is not really related to about:home.
Flags: needinfo?(dtownsend+bugmail)
Is the new search UI enabled for you? If not this is expected.
Blocks: 1101122
No longer blocks: fx34-searchui
Flags: needinfo?(dtownsend+bugmail) → needinfo?(petruta.rasa)
(In reply to Dave Townsend [:mossop] (Out till December 1st) from comment #2)
> Is the new search UI enabled for you? If not this is expected.

Yes, Nightly has it by default.
Flags: needinfo?(petruta.rasa)
Oh right, missed that this was an e10s bug
No longer blocks: 1101122
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873923
This seems worth tracking separately.
Status: RESOLVED → REOPENED
tracking-e10s: --- → ?
Depends on: 873923
Resolution: DUPLICATE → ---
Duplicate of this bug: 1111081
Duplicate of this bug: 1108080
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #5)
> This seems worth tracking separately.
why?
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #8)
> (In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #5)
> > This seems worth tracking separately.
> why?

Because we'll probably need to write an additional patch to use the new API added in bug 873923 to make this work.
And even if we didn't, bug 873923 is not explicitly about this, so it might not end up fixing it completely, and then we'd lose track of this bug in a dupe list. DUPLICATE should be used for "is the same issue", not "will be fixed by".
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Priority: -- → P3
Whiteboard: [fxsearch][searchui]
Rank: 32
Whiteboard: [fxsearch][searchui] → [ui][fxsearch]
Bug 1119250 will remove the old search bar UI entirely. See bug 1171344 for new UI details
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WONTFIX
Assignee: nobody → ursulasarracini
Duplicate of this bug: 1182417
You need to log in before you can comment on or make changes to this bug.