If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Web Audio Gain node value property is not updated after being set

RESOLVED DUPLICATE of bug 893020

Status

()

Core
Web Audio
RESOLVED DUPLICATE of bug 893020
3 years ago
2 years ago

People

(Reporter: jip, Unassigned)

Tracking

({testcase})

33 Branch
x86
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8532037 [details]
file included for easier debugging, same as http://jsfiddle.net/nvkow6r8/6

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

Open http://jsfiddle.net/nvkow6r8/6/ and click on "Run" (top).

Then click on the volume slider, first on the left side, then on the right side.


Actual results:

If you click on the left part of the slider, the volume is going to 0 in 1 second, as expected. But If you then click on the right, the volume is jumping to 1.


Expected results:

The audio gain should go to the value in 1 second, like in Chrome, and Safari. I tried with Firefox 33, and 35. It seems that the value oceanGain.gain.value, which is used to set the beginning of the ramp, is never updated. As a side problem, the debugger freezes Firefox for a while when there is a breakpoint within the function changeVolume, but it will resume (and stop sound) eventually. It is the same without any breakpoint, oceanGain.gain.value is always the initial value.
(Reporter)

Updated

3 years ago
Attachment #8532037 - Attachment description: gile included for easier debugging, same as http://jsfiddle.net/nvkow6r8/6 → file included for easier debugging, same as http://jsfiddle.net/nvkow6r8/6
(Reporter)

Comment 1

3 years ago
Attachment does not work on-line. I do not know why.

Updated

3 years ago
Component: General → Web Audio
Keywords: testcase
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
Thank you for moving the bug to the correct section... Now I see that it might be a duplicate of Bug #893020
Fixed by bug 1106649.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
There is no OscillatorNode here, so I suspect comment 3 was accidentally made on the wrong bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Woops yes, this is a correct dupe though.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893020
You need to log in before you can comment on or make changes to this bug.