If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Web Notification] Unable to show notification when the browser is re-launched

RESOLVED DUPLICATE of bug 1129315

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1129315
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: On parental leave)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8532279 [details]
logcat_20141204_WebNotification.txt

Description:
When the user requests permission on the Web Notifications Test page and selects "Allow" on the "Website Permission" dialog, both "Request Permission Result" and "Current Permission Level" become "granted". However, when the user closes the browser, re-launches the site, and requests permission, the "Website Permission" dialog does NOT appear, and only "Request Permission Result" becomes "granted". The user is unable to show a new notification.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141203040207.
2) Open Browser, and go to http://mozqa.com/qa-testcase-data/webapi/notifications/index.html
3) Select "Request Permission", and select "Allow" on the dialog.
- "Request Permission Result" and "Current Permission Level" become "granted").
4) Select "Show Notification".
- A notification pops up.
5) Close the Browser app, and re-launch the page.
6) Select "Request" again.
7) Change the title and body of the notification, and select "Show Notification".  

Actual:
(After step 6)
-"Website Permission" dialog does NOT appear. 
- Only "Request Permission Result" becomes "granted".
- "Current Permission Level" remains "default".
(After step 7)
- No notification pops up.
  
Expected: 
(After step 6)
-"Website Permission" dialog appears. 
- Both "Request Permission Result" and "Current Permission Level" become "granted".
(After step 7)
- New notification pops up.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9920/
See attached: video clip, logcat
http://youtu.be/0qsQ1Gqxjcs
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.1.

Result: "Current Permission Level" remains "default", and no new notification is shown when the site is re-launched.

Device: Flame 2.1 (319mb)(KitKat)(Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------------

This issue does NOT reproduce on Flame 2.0.

Result: "Current Permission Level" becomes "granted", and the new notification is shown when the site is re-launched.

Device: Flame 2.0 (319mb)(KitKat)(Full Flash)
Build ID: 20141203000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: 29222e215db8
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Not nominating to block on this, due to this only seeming to occur from the test site.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Can't we get a regression window, if you see it happens on 2.1 and not on 2.0 ?
Keywords: regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141017063953
Gaia: 78fe65635bff2b312ac10e05cc4ab4a9c9eaf145
Gecko: ed406b629fdf
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141017070748
Gaia: c49d6a2ab22ab5a21a248a7d4fafc5341774c1ef
Gecko: ffbc7ed93961
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Gaia & Last Working Gecko - issue does NOT repro
Gaia: c49d6a2ab22ab5a21a248a7d4fafc5341774c1ef
Gecko: ed406b629fdf

First Broken Gecko & Last Working Gaia - issue DOES repro
Gaia: 78fe65635bff2b312ac10e05cc4ab4a9c9eaf145
Gecko: ffbc7ed93961

Geck pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=ed406b629fdf&tochange=ffbc7ed93961

Caused by Bug 1068635.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
issue most likely is caused by patch to Bug 1068635 - can you take a look Fernando?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(ferjmoreno)
QA Contact: pcheng
(Assignee)

Updated

3 years ago
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129315
You need to log in before you can comment on or make changes to this bug.