[Bluetooth] Unable to send files via bluetooth

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
Last year

People

(Reporter: smiko, Assigned: zbraniecki)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing], )

Attachments

(3 attachments)

Reporter

Description

5 years ago
Posted file receivingDUT.txt
Description: When attempting to send files via bluetooth, the transfer request displays debug info rather than the pertinent info (device name, file name) Upon accepting the request, the message, "Can not complete transfer memory card is full" is displayed, even if there is plenty of space. 

Repro Steps:
1: Update a Flame to 20141205040202.
2: Open Settings > Bluetooth > and pair with another device.
3: Share a file (image,song,video) via bluetooth.

Actual: The file does not transfer. Unexpected error message is displayed. 

Expected: The file does transfer.

Environmental Variables:
Device: Flame 2.2 (319mb/full flash)
BuildID: 20141205040202
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: e7f3e6fee15e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5

See attached: logcats

Video clip: http://youtu.be/y2TVAehQh4E
Reporter

Comment 1

5 years ago
Notes:
1: This issue does NOT occur when sending files from 2.2 to 2.1

Actual result: Files transfer via bluetooth. 
________________________________________________________________________________________________________

This issue does NOT repro on Flame 2.1 (319mb/full flash) or yesterday's 2.2 (319mb/full flash) build.

Actual result: Files transfer via bluetooth

Environmental Variables:
Device: Flame 2.1
BuildID: 20141205001201
Gaia: 38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko: 8b92c4b8f59a
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.2 
BuildID: 20141204040202
Gaia: 984e6d79aa799d2695f9ca132dfdc1665a56c019
Gecko: a9fc46355661
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.2-Daily-Testing]
Reporter

Comment 2

5 years ago
Posted file sendingDUT.txt
Functional regression that breaks smoke tests, requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Some information for others working on this issue.  This bug is on the receiving phone as it can be reproduced between a flame and devices that are not Firefox OS such as the "Motoroloa Droid MAXX" for example.

Finding the regression window now.
QA Contact: jmercado
Bug 1095109 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141204082246
Gaia: a208afd47dd0f9633068ada61bc9829b5a2bed7a
Gecko: 643a2477719e
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141204090247
Gaia: 256ffaa7ae85bc95cae269482fae7314fdbf2cc6
Gecko: 07a5a56ccf69
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: a208afd47dd0f9633068ada61bc9829b5a2bed7a
Gecko: 07a5a56ccf69

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 256ffaa7ae85bc95cae269482fae7314fdbf2cc6
Gecko: 643a2477719e

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/a208afd47dd0f9633068ada61bc9829b5a2bed7a...256ffaa7ae85bc95cae269482fae7314fdbf2cc6
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
possibly broken by the patch to Bug 1095109  -  can you take a look Gandalf?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gandalf)
QA Contact: jmercado
taking.
Assignee: nobody → gandalf
Flags: needinfo?(gandalf)
agh, trivial bug. Accidentally tookover the wrong evt object when passing to the showReceivePrompt.
Status: NEW → ASSIGNED
Comment on attachment 8532759 [details] [review]
[PullReq] zbraniecki:1108030-fix-bluetooth-transfer to mozilla-b2g:master

since it's a trivial regression, I'm going to go ahead and give myself a self-r+.

Kevin, if this is not acceptable, please, let me know and I'll request a proper review from the Bluetooth owner.
Flags: needinfo?(kgrandon)
Attachment #8532759 - Flags: review+
That sounds fine to me. I'll add a R+ and move it into the system app in case you feel like using autolander (needs a suggested reviewer).
Component: Bluetooth → Gaia::System
Flags: needinfo?(kgrandon)
Attachment #8532759 - Flags: review?(kgrandon)
Comment on attachment 8532759 [details] [review]
[PullReq] zbraniecki:1108030-fix-bluetooth-transfer to mozilla-b2g:master

Oops, meant to + that :)
Attachment #8532759 - Flags: review?(kgrandon) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue still reproduces on Flame 2.2.

Result: Error message is displayed, and file transfer cannot be done.

Device: Flame 2.2 (319mb, KK, Full Flash)
BuildID: 20141208040202
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: c4c7442e9113
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
I cant reproduce it anymore with Flame master with the patch but lets inestigate more. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: in-qa-testsuite?(gmealer)
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage+][failed-verification] [fxosqa-auto-backlog+]
Flags: in-qa-testsuite?(gmealer)
Can we recheck this verification.  We pulled latest gaia and the bug doesn't occur.  I don't think the build in comment 14 got the patch included in it.
QA Whiteboard: [QAnalyst-Triage+][failed-verification] [fxosqa-auto-backlog+] → [QAnalyst-Triage-][failed-verification] [fxosqa-auto-backlog+]
Keywords: qaurgent, qawanted
Re-verified with latest central tinderbox engineering build and issue is fixed. I was able to pair up with another device and successfully receive/sent 5 image files via Bluetooth.

Device: Flame 2.2 Master (shallow/full flash, 319MB mem)
BuildID: 20141208124704
Gaia: bd4dcc8c4582e2368b47b0e62506d3031fb2fc09
Gecko: f1f48ccb2d4e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage-][failed-verification] [fxosqa-auto-backlog+] → [QAnalyst-Triage?][failed-verification] [fxosqa-auto-backlog+]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
Resolution: --- → FIXED
Marking the bug as verified fixed per Comment 17.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][failed-verification] [fxosqa-auto-backlog+] → [QAnalyst-Triage?][fxosqa-auto-backlog+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog+] → [QAnalyst-Triage+][fxosqa-auto-backlog+]
Flags: needinfo?(ktucker)
Flags: needinfo?(jmitchell)
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.