If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<Hr> elements ignore CSS floated elements and write over the top

RESOLVED DUPLICATE of bug 84887

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 84887
16 years ago
16 years ago

People

(Reporter: Caleb Maclennan, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

user/pass for the above site is studio/dev

<hr> elements overlap floated box objects.

Reproducible: Always
Steps to Reproduce:
You can create the effect easily on a new page. Create a Div object and use CSS
to float it right. then create some text that flows around the div. In that text
create a horizontal rule such that the rule should be beside the box. Instead of
stoping when it reaches the div, it runs right across the top of it.

Expected Results:  stop the <hr> at the same place the text stops at.
Duplicate of "[FLOAT] <hr> is drawn over complete page in standards mode"

In quirks mode we do the backwards-compatible behavior.  In standards mode <hr>
is a block element and acts like one.

*** This bug has been marked as a duplicate of 84887 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
This should probably be considered a bug in the specs, not a bug in Mozilla.

The solution for webmasters is to redefine hr to be an inline element:

hr { display : inline }

... whenever a strct DTD is used.
Severity: normal → minor
You need to log in before you can comment on or make changes to this bug.