Closed Bug 1108154 Opened 8 years ago Closed 6 years ago

Create try-extender

Categories

(Taskcluster :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1254325

People

(Reporter: jlal, Unassigned)

References

Details

After speaking with RyanVM I found some additional tooling we need to fully replace self-serve one of these is what I call "try-extender".

Try-extender is a UI which lists try flags from a given branch / revision (this should load from the in-tree configs in taskcluster) and presents a UI of all the flags. These check boxes are used to create a decision task which will extend an existing push with extra jobs.

Why? This is used primarily in the case where we need to debug problems (in lets say b2g-inbound) in periodic tasks. Currently this is done manually by creating the missing periodic tasks and seeing which commit the issue was created in.
Blocks: 1080265
Not sure how this fits in with the mozci plans.
James, would you mind if we spoke in Whistler about this?
I should have some POC of mozci+TC support.

For the record, this sounds more like a dynamic trychooser (we're not limiting it to try, right?) *and* triggering what is selected.
We've talked about setting something like this up but I did not want to tackle it without TC support.

http://mozilla-ci-tools.readthedocs.org/en/master/use_cases.html#case-scenario-9-we-generate-data-to-build-a-dynamic-trychooser-ui
please keep the conversations/summaries public.  :gma_fav is looking into similar bugs and keeping everyone in the loop will help.
We will.
Is that bug 983802?
yes, these bugs seem very much related.
Component: TaskCluster → General
Product: Testing → Taskcluster
I believe this depends on bug 1107597

Note:
* Creating an up-to-date trychooser is a different problem that this bug
* Once bug 1107597 is fixed we can have a UI that allows removing tasks that had not been scheduled by removing the self-dependencies of those tasks.
Depends on: 1107597
The equivalent bug for the buildbot set up is bug 1185537.
No longer blocks: 1080265
Armen, pulse_actions has given us this functionality, right?
Yes, martianwars accomplished this in bug 1254325.

pulse_actions + treeherder + action tasks
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254325
You need to log in before you can comment on or make changes to this bug.